summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-01 19:44:48 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:46 -0500
commit1703eb051609561a08bf1f267a30e9e68f9ef60a (patch)
tree9e7de73fe76c0303a74767252c3d578ec6a641f5 /sci-libs/spqr
parentsci-libs/cholmod: new version 3.0.13. (diff)
downloadgentoo-1703eb051609561a08bf1f267a30e9e68f9ef60a.tar.gz
gentoo-1703eb051609561a08bf1f267a30e9e68f9ef60a.tar.bz2
gentoo-1703eb051609561a08bf1f267a30e9e68f9ef60a.zip
sci-libs/spqr: new version 2.0.9.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. This version uses a "partition" USE flag instead of "metis", to more closely match the terminology used upstream and by sci-libs/cholmod. Bug: https://bugs.gentoo.org/492484 Bug: https://bugs.gentoo.org/586582 Bug: https://bugs.gentoo.org/654548 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/Manifest1
-rw-r--r--sci-libs/spqr/metadata.xml4
-rw-r--r--sci-libs/spqr/spqr-2.0.9.ebuild33
3 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/spqr/Manifest b/sci-libs/spqr/Manifest
index 2ce771078d81..0e91983a9460 100644
--- a/sci-libs/spqr/Manifest
+++ b/sci-libs/spqr/Manifest
@@ -1,2 +1,3 @@
DIST SPQR-1.2.3.tar.gz 1090017 BLAKE2B 7ecd180f2147229bea7d9230c5f645c1d835e7260d58930ab8021c7d90b3b7992d708af942beaa728bce86e83e008db9ecb7d69cb7a3b1245bab1c9c9bf7c4c6 SHA512 1abcde88e157bc99445e3589cacd6aba875429f1cdef87e36e1d6943c1474a2f8df9a65eff99e92d72e346c02f11194b6ec6829c158f42f689f95845c9b11599
DIST spqr-1.3.1.tar.bz2 1115795 BLAKE2B 027509745cd336d3ccff27a4f36e51493fb9008fabb84448ba559b561269861be97d86ec841674c2bc944eb86623675b223947fcccf0716052a899ce17850d32 SHA512 1c7644da2bb7a14b9bc26066b84355626ce5d7c396afe5ce496ae72a5ef54431dc817178bfe7dd69ddf586b661c44066ee0850c91dba846a32787d52607749bf
+DIST spqr-2.0.9.tar.bz2 2161068 BLAKE2B a662983d2543a65ce36a367749db5585308acb56b016f69a35c46a84e9c12a678f57a3cfd459cc2e887fff2819b00f99981efaadb73831f1b4c54cbef5e1c367 SHA512 54b203e0d68b266473b8a2b7b3b3a55476df54a3ebd5748b70faa7bad1d0a5a7387197f0674ba5f9a5d45887daa736117f8d6ffbbc2eb02482b3374a3babf721
diff --git a/sci-libs/spqr/metadata.xml b/sci-libs/spqr/metadata.xml
index c7ab54f2c476..0d8618db4112 100644
--- a/sci-libs/spqr/metadata.xml
+++ b/sci-libs/spqr/metadata.xml
@@ -14,6 +14,10 @@
</longdescription>
<use>
<flag name="metis">Use <pkg>sci-libs/metis</pkg> or <pkg>sci-libs/parmetis</pkg> for partitioning</flag>
+ <flag name="partition">
+ Use the partition module of <pkg>sci-libs/cholmod</pkg> for
+ partitioning
+ </flag>
<flag name="tbb">Enable multithreading with the Intel Threads
Building Block <pkg>dev-cpp/tbb</pkg></flag>
</use>
diff --git a/sci-libs/spqr/spqr-2.0.9.ebuild b/sci-libs/spqr/spqr-2.0.9.ebuild
new file mode 100644
index 000000000000..16aea9c33e72
--- /dev/null
+++ b/sci-libs/spqr/spqr-2.0.9.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc partition static-libs tbb"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+# We require the cholmod supernodal module that is enabled with
+# USE=lapack, and cholmod has to have partition support if spqr is going
+# to have it (the ./configure script for spqr checks this). Note that
+# spqr links to metis directly, too.
+DEPEND="virtual/lapack
+ >=sci-libs/cholmod-2[lapack,partition?]
+ partition? ( >=sci-libs/metis-5.1.0 )
+ tbb? ( dev-cpp/tbb )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_with doc) \
+ $(use_enable static-libs static) \
+ $(use_with partition) \
+ $(use_with tbb)
+}