summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-12-24 08:32:21 -0600
committerMatthias Maier <tamiko@gentoo.org>2019-12-24 08:47:35 -0600
commit8537444806d831ac0a5fe847d0da95c446aaea87 (patch)
tree0e7ad9f7c387e322fb92f58de0516fbe33f4b188 /sci-libs/sundials
parentsci-libs/dealii: update dependency on sundials (diff)
downloadgentoo-8537444806d831ac0a5fe847d0da95c446aaea87.tar.gz
gentoo-8537444806d831ac0a5fe847d0da95c446aaea87.tar.bz2
gentoo-8537444806d831ac0a5fe847d0da95c446aaea87.zip
sci-libs/sundials: version bump to 5.0.0
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/sundials')
-rw-r--r--sci-libs/sundials/Manifest1
-rw-r--r--sci-libs/sundials/files/sundials-5.0.0-fix-license-install-path.patch16
-rw-r--r--sci-libs/sundials/sundials-5.0.0.ebuild69
3 files changed, 86 insertions, 0 deletions
diff --git a/sci-libs/sundials/Manifest b/sci-libs/sundials/Manifest
index e3e6893d43fc..b98d5eaf31f4 100644
--- a/sci-libs/sundials/Manifest
+++ b/sci-libs/sundials/Manifest
@@ -1,3 +1,4 @@
DIST sundials-3.2.1.tar.gz 14958699 BLAKE2B ecc4b454ec589e9177acc9375e1db370ad6281f8d29580d9558ad3146dbbaab52794013e9cb56ad83f7309dbd3084a1ccaf6972c6b1468cefcc86bf30d3a460c SHA512 1f3e4b12f368e4f50c38b970c012f1702e339319ee0a858661bdf83e5739bb5b8a36f98b82e2ef76d1ce8a473123046347ee1b44f3cb685509823864f0af1384
DIST sundials-4.0.2.tar.gz 17183377 BLAKE2B e322a978186f41d84a936faa55962ef6794bf99d6c6a108bfa2bd5615f27f32f7ab6ca4989802fa052d3132b53dca3069b7e4ec9941f95efb92de7bf0792dd88 SHA512 6d0a6fc49c695e70593da71892f0906585dee9c94899bb6b8c9a56c85f345809565166a62544647fdac411d22e37276b9b1bb78ba9be46eaeb28dcd3f6162ef5
DIST sundials-4.1.0.tar.gz 17221960 BLAKE2B 598c7adc9e37fcfb1f44a3235f58af489ad907d053cb67ee0d3b076076621958374eb847e48318ddf7ced85a7601c5330ac640c7abe8723aaee7d650e3298b8d SHA512 1922dca3f0b8869098670aede802e48abec39607c96304e4efd9b03d195b16920175846fce10641aeebc48c216bda73c8691139dce57ffa7731a6bc8194b81b0
+DIST sundials-5.0.0.tar.gz 18820465 BLAKE2B 77bc7bd489b52ff316f3e889aad4ec27830c42650591270443d45a0aa958d06663e93931a8933ca2d228619263219be4d7441cb473eaaedeab958ae47418a44e SHA512 4962adabcde19207b5044d1e63758d58b5d3cfeefcd0eae65ddfe5499931bf19fa98bafbd4742045cc255f6b4a45653f41df7a7739f86d6eb47c79c9312b4471
diff --git a/sci-libs/sundials/files/sundials-5.0.0-fix-license-install-path.patch b/sci-libs/sundials/files/sundials-5.0.0-fix-license-install-path.patch
new file mode 100644
index 000000000000..5de76573630a
--- /dev/null
+++ b/sci-libs/sundials/files/sundials-5.0.0-fix-license-install-path.patch
@@ -0,0 +1,16 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d5436bf..76b27c5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1122,9 +1122,9 @@ endif()
+ # install license and notice files
+ install(
+ FILES ${PROJECT_SOURCE_DIR}/LICENSE
+- DESTINATION include/sundials
++ DESTINATION share/doc/sundials-5.0.0
+ )
+ install(
+ FILES ${PROJECT_SOURCE_DIR}/NOTICE
+- DESTINATION include/sundials
++ DESTINATION share/doc/sundials-5.0.0
+ )
diff --git a/sci-libs/sundials/sundials-5.0.0.ebuild b/sci-libs/sundials/sundials-5.0.0.ebuild
new file mode 100644
index 000000000000..9505cbb40bfd
--- /dev/null
+++ b/sci-libs/sundials/sundials-5.0.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_MAKEFILE_GENERATOR="emake"
+FORTRAN_NEEDED=fortran
+FORTRAN_STANDARD=90
+
+inherit cmake-utils toolchain-funcs fortran-2
+
+DESCRIPTION="Suite of nonlinear solvers"
+HOMEPAGE="https://computation.llnl.gov/projects/sundials"
+SRC_URI="https://computation.llnl.gov/projects/sundials/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cxx doc examples fortran hypre lapack mpi openmp sparse static-libs superlumt threads"
+REQUIRED_USE="hypre? ( mpi )"
+
+RDEPEND="
+ lapack? ( virtual/lapack )
+ mpi? ( virtual/mpi sci-libs/hypre:= )
+ sparse? ( sci-libs/klu:= )
+ superlumt? ( sci-libs/superlu_mt:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-license-install-path.patch )
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp && [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
+ ewarn "OpenMP is not available in your current selected gcc"
+ die "need openmp capable gcc"
+ fi
+}
+
+src_configure() {
+ mycmakeargs+=(
+ -DBUILD_SHARED_LIBS=ON
+ -DBUILD_STATIC_LIBS="$(usex static-libs)"
+ -DCXX_ENABLE="$(usex cxx)"
+ -DFCMIX_ENABLE="$(usex fortran)"
+ -DF90_ENABLE="$(usex fortran)"
+ -DHYPRE_ENABLE="$(usex hypre)"
+ -DHYPRE_INCLUDE_DIR="${EPREFIX}/usr/include/hypre"
+ -DKLU_ENABLE="$(usex sparse)"
+ -DKLU_LIBRARY="${EPREFIX}/usr/$(get_libdir)/libklu.so"
+ -DLAPACK_ENABLE="$(usex lapack)"
+ -DMPI_ENABLE="$(usex mpi)"
+ -DOPENMP_ENABLE="$(usex openmp)"
+ -DPTHREAD_ENABLE="$(usex threads)"
+ -DSUPERLUMT_ENABLE="$(usex superlumt)"
+ -DSUPERLUMT_INCLUDE_DIR="${EPREFIX}/usr/include/superlu_mt"
+ -DSUPERLUMT_LIBRARY="-lsuperlu_mt"
+ -DEXAMPLES_ENABLE="$(usex examples)"
+ -DEXAMPLES_INSTALL=ON
+ -DEXAMPLES_INSTALL_PATH="/usr/share/doc/${PF}/examples"
+ -DUSE_GENERIC_MATH=ON
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc doc/*/*.pdf
+}