summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2019-09-28 12:03:16 +0200
committerDavid Seifert <soap@gentoo.org>2019-10-20 14:47:58 +0200
commite155288972e5439827ac9d0c30f7904a1d753caa (patch)
tree0f25f4faf229d834f2ea89083b2166bcb556259c /sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
parentprofiles/package.mask: mask ruby24-only packages for removal (diff)
downloadgentoo-e155288972e5439827ac9d0c30f7904a1d753caa.tar.gz
gentoo-e155288972e5439827ac9d0c30f7904a1d753caa.tar.bz2
gentoo-e155288972e5439827ac9d0c30f7904a1d753caa.zip
sci-libs/tamu_anova: various fixes
* EAPI 7 bump * disable static library * added missing build dep * Debian as new upstream Closes: https://bugs.gentoo.org/617806 Closes: https://github.com/gentoo/gentoo/pull/13071 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild')
-rw-r--r--sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
new file mode 100644
index 000000000000..36f86cfa54bf
--- /dev/null
+++ b/sci-libs/tamu_anova/tamu_anova-0.2-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="ANOVA Extensions to the GNU Scientific Library"
+HOMEPAGE="https://tracker.debian.org/pkg/tamuanova"
+SRC_URI="http://cdn-fastly.deb.debian.org/debian/pool/main/t/tamuanova/tamuanova_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="sci-libs/gsl:0="
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/texinfo"
+
+S="${WORKDIR}"/${PN}-0.2
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-gentoo.patch
+ "${FILESDIR}"/${P}-texinfo5.1.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}