summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/taucs/taucs-2.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/taucs/taucs-2.2.ebuild')
-rw-r--r--sci-libs/taucs/taucs-2.2.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/sci-libs/taucs/taucs-2.2.ebuild b/sci-libs/taucs/taucs-2.2.ebuild
new file mode 100644
index 000000000000..0581af618f6a
--- /dev/null
+++ b/sci-libs/taucs/taucs-2.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="C library of sparse linear solvers"
+HOMEPAGE="http://www.tau.ac.il/~stoledo/taucs/"
+SRC_URI="http://www.tau.ac.il/~stoledo/${PN}/${PV}/${PN}.tgz -> ${P}.tgz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="cilk doc static-libs"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack
+ || ( sci-libs/metis sci-libs/parmetis )
+ cilk? ( dev-lang/cilk )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ # test with cilk has memory leaks
+ epatch "${FILESDIR}"/${P}-no-test-cilk.patch
+}
+
+src_configure() {
+ cat > config/linux_shared.mk <<-EOF
+ FC=$(tc-getFC)
+ CC=$(tc-getCC)
+ LD=$(tc-getFC)
+ CFLAGS=${CFLAGS} -fPIC
+ FFLAGS=${FFLAGS} -fPIC
+ LDFLAGS=${LDFLAGS} -fPIC
+ LIBBLAS=$($(tc-getPKG_CONFIG) --libs blas)
+ LIBLAPACK=$($(tc-getPKG_CONFIG) --libs lapack)
+ LIBF77=
+ EOF
+
+ echo "LIBMETIS=$($(tc-getPKG_CONFIG) --libs metis)" >> config/linux_shared.mk
+ # no cat <<EOF because -o has a trailing space
+ if use cilk; then
+ echo "CILKC=cilkc" >> config/linux_shared.mk
+ echo "CILKFLAGS=-O2 -I${EPREFIX}/usr/include/cilk -fPIC" >> config/linux_shared.mk
+ echo "CILKOUTFLG=-o " >> config/linux_shared.mk
+ fi
+ sed -e 's/ -fPIC//g' \
+ config/linux_shared.mk \
+ > config/linux_static.mk || die
+}
+
+src_compile() {
+ # not autotools configure
+ if use static-libs; then
+ ./configure variant=_static || die
+ emake
+ fi
+ ./configure variant=_shared || die
+ emake
+
+ cd lib/linux_shared
+ $(tc-getFC) ${LDFLAGS} -shared -Wl,-soname=libtaucs.so.1 \
+ -Wl,--whole-archive libtaucs.a -Wl,--no-whole-archive \
+ $($(tc-getPKG_CONFIG) --libs blas lapack metis) \
+ -o libtaucs.so.1.0.0 \
+ || die "shared lib linking failed"
+}
+
+src_test() {
+ LD_LIBRARY_PATH=lib/linux_shared \
+ ./testscript variant=_shared || die "compile test failed"
+ if grep -q FAILED testscript.log; then
+ eerror "Test failed. See ${S}/testscript.log"
+ die "test failed"
+ fi
+}
+
+src_install() {
+ use static-libs && dolib.a lib/linux_static/libtaucs.a
+ ln -s libtaucs.so.1.0.0 lib/linux_shared/libtaucs.so.1
+ ln -s libtaucs.so.1 lib/linux_shared/libtaucs.so
+ dolib.so lib/linux_shared/libtaucs.so*
+
+ insinto /usr/include
+ doins build/*/*.h src/*.h
+
+ use doc && dodoc doc/*.pdf
+}