summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/ufconfig/ufconfig-3.5.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/ufconfig/ufconfig-3.5.0.ebuild')
-rw-r--r--sci-libs/ufconfig/ufconfig-3.5.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/ufconfig/ufconfig-3.5.0.ebuild b/sci-libs/ufconfig/ufconfig-3.5.0.ebuild
new file mode 100644
index 000000000000..6cfed5e96706
--- /dev/null
+++ b/sci-libs/ufconfig/ufconfig-3.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib toolchain-funcs
+
+MY_PN=UFconfig
+DESCRIPTION="Common configuration scripts for the SuiteSparse libraries"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/UFconfig"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+DEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_compile() {
+ echo "$(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo"
+ $(tc-getCC) ${CFLAGS} -fPIC -c UFconfig.c -o UFconfig.lo || die
+ echo "$(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo"
+ $(tc-getCC) ${LDFLAGS} -shared -Wl,-soname,libufconfig.so.${PV} -o libufconfig.so.${PV} UFconfig.lo || die
+ if use static-libs; then
+ echo "$(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o"
+ $(tc-getCC) ${CFLAGS} -c UFconfig.c -o UFconfig.o || die
+ echo "$(tc-getAR) libufconfig.a UFconfig.o"
+ $(tc-getAR) cr libufconfig.a UFconfig.o
+ fi
+}
+
+src_install() {
+ dolib.so libufconfig.so.${PV} || die
+ dosym libufconfig.so.${PV} /usr/$(get_libdir)/libufconfig.so
+ if use static-libs; then
+ dolib.a libufconfig.a || die
+ fi
+ insinto /usr/include
+ doins UFconfig.h || die
+ dodoc README.txt || die
+}