summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2020-05-12 08:57:45 -0500
committerMatthias Maier <tamiko@gentoo.org>2020-05-12 10:34:15 -0500
commit3f2c91135dfa6781d30f033979b5c751bb4a849b (patch)
tree804a4fc5bfb4478d97cb52e3284fec472fecc6ed /sci-libs/vtk/vtk-8.2.0.ebuild
parentx11-terms/mlterm: drop old (diff)
downloadgentoo-3f2c91135dfa6781d30f033979b5c751bb4a849b.tar.gz
gentoo-3f2c91135dfa6781d30f033979b5c751bb4a849b.tar.bz2
gentoo-3f2c91135dfa6781d30f033979b5c751bb4a849b.zip
sci-libs/vtk: fix 8.2.0 ebuild
- fix bundled libproj configuration. Thanks to Tiernan Hubble for pointing this out - use system mpi4py Closes: https://bugs.gentoo.org/720372 Closes: https://bugs.gentoo.org/721412 Closes: https://bugs.gentoo.org/721802 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs/vtk/vtk-8.2.0.ebuild')
-rw-r--r--sci-libs/vtk/vtk-8.2.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/sci-libs/vtk/vtk-8.2.0.ebuild b/sci-libs/vtk/vtk-8.2.0.ebuild
index 8f8191938e71..ee000cf9d837 100644
--- a/sci-libs/vtk/vtk-8.2.0.ebuild
+++ b/sci-libs/vtk/vtk-8.2.0.ebuild
@@ -167,7 +167,7 @@ src_configure() {
-DVTK_USE_SYSTEM_GL2PS=OFF
-DVTK_USE_SYSTEM_HDF5=ON
-DVTK_USE_SYSTEM_JPEG=ON
- -DVTK_USE_SYSTEM_LIBPROJ4=OFF
+ -DVTK_USE_SYSTEM_LIBPROJ=OFF
-DVTK_USE_SYSTEM_LIBXML2=ON
-DVTK_USE_SYSTEM_LibXml2=ON
-DVTK_USE_SYSTEM_NETCDF=ON
@@ -198,6 +198,7 @@ src_configure() {
-DVTK_Group_Tk=$(usex tk)
-DVTK_Group_Views=$(usex views)
-DVTK_Group_Web=$(usex web)
+ -DVTK_SMP_IMPLEMENTATION_TYPE="$(usex tbb TBB Sequential)"
-DVTK_WWW_DIR="${ED}/${MY_HTDOCSDIR}"
-DVTK_WRAP_JAVA=$(usex java)
-DVTK_WRAP_PYTHON=$(usex python)
@@ -230,10 +231,8 @@ src_configure() {
mycmakeargs+=( -DJAVAC_OPTIONS=${javacargs// /;} )
fi
- if use tbb; then
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="TBB" )
- else
- mycmakeargs+=( -DVTK_SMP_IMPLEMENTATION_TYPE="Sequential" )
+ if use mpi; then
+ mycmakeargs+=( -DVTK_USE_SYSTEM_MPI4PY=ON )
fi
if use python; then