summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-06 11:46:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-06 11:48:20 +0200
commit49f290c037ace1ceb2ef4a6b7800baa262d3149d (patch)
treeb3b90bdad86caed86a318d80c16cb4813edd6612 /sci-libs/vtk
parentsci-libs/vtk: Drop 8.1.0-r7 (diff)
downloadgentoo-49f290c037ace1ceb2ef4a6b7800baa262d3149d.tar.gz
gentoo-49f290c037ace1ceb2ef4a6b7800baa262d3149d.tar.bz2
gentoo-49f290c037ace1ceb2ef4a6b7800baa262d3149d.zip
sci-libs/vtk: Fix build with -fno-common
Thanks-to: Tiernan Hubble <tiernanhubble+gentoo@gmail.com> Closes: https://bugs.gentoo.org/721048 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/files/vtk-8.2.0-fno-common.patch40
-rw-r--r--sci-libs/vtk/vtk-8.2.0.ebuild1
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/vtk/files/vtk-8.2.0-fno-common.patch b/sci-libs/vtk/files/vtk-8.2.0-fno-common.patch
new file mode 100644
index 000000000000..d7268ef7566b
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-8.2.0-fno-common.patch
@@ -0,0 +1,40 @@
+From a9079bdccbb2165583d6773a5ed848427e2a38a8 Mon Sep 17 00:00:00 2001
+From: Seacas Upstream <kwrobot@kitware.com>
+Date: Tue, 28 Jan 2020 09:13:38 -0500
+Subject: [PATCH] exodusII 2020-01-28 (d97eb08d)
+
+Code extracted from:
+
+ https://gitlab.kitware.com/third-party/seacas.git
+
+at commit d97eb08d79e87c82facfae39bc75deb60c0a2d83 (for/vtk-20200128-7.24f-v2019-12-18).
+---
+ ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c | 2 +-
+ ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c b/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
+index 8d5d6734f0..ef439618da 100644
+--- a/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
++++ b/ThirdParty/exodusII/vtkexodusII/src/ex_create_par.c
+@@ -216,5 +216,5 @@ int ex_create_par_int(const char *path, int cmode, int *comp_ws, int *io_ws, MPI
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_create_par;
+ #endif
+diff --git a/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c b/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
+index b2faa22c29..9df4818767 100644
+--- a/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
++++ b/ThirdParty/exodusII/vtkexodusII/src/ex_open_par.c
+@@ -459,5 +459,5 @@ int ex_open_par_int(const char *path, int mode, int *comp_ws, int *io_ws, float
+ * Prevent warning in some versions of ranlib(1) because the object
+ * file has no symbols.
+ */
+-const char exodus_unused_symbol_dummy_1;
++const char exodus_unused_symbol_dummy_ex_open_par;
+ #endif
+--
+2.26.2
+
diff --git a/sci-libs/vtk/vtk-8.2.0.ebuild b/sci-libs/vtk/vtk-8.2.0.ebuild
index 3ad36f8c4463..6da25f5916c4 100644
--- a/sci-libs/vtk/vtk-8.2.0.ebuild
+++ b/sci-libs/vtk/vtk-8.2.0.ebuild
@@ -127,6 +127,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-8.1.0-openmpi-4-compatibility.patch
"${FILESDIR}"/${P}-qt-5.15.patch # bug 726960
"${FILESDIR}"/${P}-gcc-10.patch # bug 723374
+ "${FILESDIR}"/${P}-fno-common.patch # bug 721048
)
RESTRICT="test"