summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-27 00:42:55 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-27 00:59:19 -0400
commit4d9e8c629da1a95d7ce2bc033995dee5930acd25 (patch)
treee5cf8a07be8e24a6d325f5e97e876a3bfd037701 /sci-libs
parentnet-mail/getmail: version bump to 4.52.0 (diff)
downloadgentoo-4d9e8c629da1a95d7ce2bc033995dee5930acd25.tar.gz
gentoo-4d9e8c629da1a95d7ce2bc033995dee5930acd25.tar.bz2
gentoo-4d9e8c629da1a95d7ce2bc033995dee5930acd25.zip
sci-libs/matio: version bump to 1.5.9
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/matio/Manifest1
-rw-r--r--sci-libs/matio/matio-1.5.9.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-libs/matio/Manifest b/sci-libs/matio/Manifest
index f3bba607e5da..b282e0a24faa 100644
--- a/sci-libs/matio/Manifest
+++ b/sci-libs/matio/Manifest
@@ -2,3 +2,4 @@ DIST matio-1.5.1.tar.gz 8160893 SHA256 7d94a1433f67ce21f08fbbfc8af677f3838964b2b
DIST matio-1.5.2.tar.gz 8179926 SHA256 db02d0fb3373c3d766a606309b17e64a5d8da55610e921a9f1a0ec171e911d45 SHA512 47ee7457db3f2138ecb1db9d7a04bf91d8277024631694e5f5a49b77829d60ce9dd95a1db33cd8eeaa8271e942acf60b522f40e4d7f4cae90f0a7caee7eb6efc WHIRLPOOL 31796367020078b06cefa10ccfad00526a04c12c158f581d8b4c134071647f01ae55b39e1c738cc3a9ac6211f36cd59041130edd208f001a28fb9f770e0fe8b0
DIST matio-1.5.7.tar.gz 8502196 SHA256 84b9a17ada1ee08374fb47cc2d0e10a95b8f7f603b58576239f90b8c576fad48 SHA512 03ba3732aeb9f8d7f94d7e95d409ae7abbed5172f033b6a5752dfb74a2c1fdf61e4f3a9a34bccae1d37e9dbfb3ef6415420b7ea0533265fb338cc6600b758e90 WHIRLPOOL 3bf2512682ef0299c1a4d3f99539e170894af129de485af04eb4f16c271a762fe52a6fe697e4acecedc661e9a4b0d50d702fa7ad127f425ae51e18dc34bbbb78
DIST matio-1.5.8.tar.gz 8533752 SHA256 6e49353d1d9d5127696f2e67b46cf9a1dc639663283c9bc4ce5280489c03e1f0 SHA512 6a3dbb05f349c8e9cd1fd46a5e9a38cadaf51ff3fd345aa6eff38fd528c58edc0c1ec6f6d5b81f944b60d10077da666ebf36b763a0d25c13a260a5925bc08d8f WHIRLPOOL 0822dcd87135134e4bd4d367c6c31cfbf7aa22279c013bcbd4eae94480384bf566b7b235e96e7b89cff8f6123d6edaa2b0f926a5f7af9662881867c202178558
+DIST matio-1.5.9.tar.gz 8520329 SHA256 beb7f965831ec5b4ef43f8830ee1ef1c121cd98e11b0f6e1d98713d9f860c05c SHA512 e6162a1034bf03523ddab34e3dbfe01a4993b419a36e31702f4cdede3fa541b1acad26bf2a79688babf90497310ac7af599d3b1ab1e0c3321607e826c4dca4da WHIRLPOOL e45c8a63a00fdac0be459513d11854d29a94afd008ee9388cc64be7ac1b507cf48efd3f578484b172642adb0927ef1ecfb3585ce11211dfc648b62749cda5ace
diff --git a/sci-libs/matio/matio-1.5.9.ebuild b/sci-libs/matio/matio-1.5.9.ebuild
new file mode 100644
index 000000000000..7b8db24263d2
--- /dev/null
+++ b/sci-libs/matio/matio-1.5.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Library for reading and writing matlab files"
+HOMEPAGE="https://sourceforge.net/projects/matio/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0/4" # subslot = soname version
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples hdf5 sparse static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ hdf5? ( sci-libs/hdf5 )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ econf \
+ $(use_enable hdf5 mat73) \
+ $(use_enable sparse extended-sparse) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ use doc && emake -C documentation pdf
+}
+
+src_install() {
+ default
+
+ use doc && dodoc documentation/matio_user_guide.pdf
+ if use examples; then
+ docinto examples
+ dodoc test/test*
+ insinto /usr/share/${PN}
+ doins share/test*
+ fi
+
+ find "${D}" -name "*.la" -delete || die
+}