summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-16 10:12:19 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-16 10:12:19 +0200
commit4fd9cba02c85e6a99cadae42dcef198ac14dcc84 (patch)
tree7dfd3cd2b37f10b39894613b4ce13caedd4aaf6b /sci-libs
parentsci-libs/coinor-csdp: [QA] use tc-check-openmp correctly (diff)
downloadgentoo-4fd9cba02c85e6a99cadae42dcef198ac14dcc84.tar.gz
gentoo-4fd9cba02c85e6a99cadae42dcef198ac14dcc84.tar.bz2
gentoo-4fd9cba02c85e6a99cadae42dcef198ac14dcc84.zip
sci-libs/kissfft: [QA] use tc-check-openmp correctly
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/kissfft/kissfft-131.1.0.ebuild6
-rw-r--r--sci-libs/kissfft/kissfft-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-libs/kissfft/kissfft-131.1.0.ebuild b/sci-libs/kissfft/kissfft-131.1.0.ebuild
index 719285275283..bc06fee4c8e0 100644
--- a/sci-libs/kissfft/kissfft-131.1.0.ebuild
+++ b/sci-libs/kissfft/kissfft-131.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -36,6 +36,10 @@ python_check_deps() {
has_version -d "dev-python/numpy[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
use test && python-any-r1_pkg_setup
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
diff --git a/sci-libs/kissfft/kissfft-9999.ebuild b/sci-libs/kissfft/kissfft-9999.ebuild
index 719285275283..bc06fee4c8e0 100644
--- a/sci-libs/kissfft/kissfft-9999.ebuild
+++ b/sci-libs/kissfft/kissfft-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -36,6 +36,10 @@ python_check_deps() {
has_version -d "dev-python/numpy[${PYTHON_USEDEP}]"
}
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
use test && python-any-r1_pkg_setup
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp