summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2021-05-01 13:09:07 +1200
committerMichael Orlitzky <mjo@gentoo.org>2021-05-02 20:04:33 -0400
commit6eac6b8ce698c2e872cb5a22aaaafca9b4f241e3 (patch)
tree25ff64915605eaefff1624dfca1c056c66870a9a /sci-libs
parentsys-kernel/gentoo-sources: Liunux 5.12.1 and genpatches (diff)
downloadgentoo-6eac6b8ce698c2e872cb5a22aaaafca9b4f241e3.tar.gz
gentoo-6eac6b8ce698c2e872cb5a22aaaafca9b4f241e3.tar.bz2
gentoo-6eac6b8ce698c2e872cb5a22aaaafca9b4f241e3.zip
sci-libs/fplll: Add upstreamed patch for gcc11
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Closes: https://bugs.gentoo.org/786858 Closes: https://github.com/gentoo/gentoo/pull/20622 Signed-off-by: François René Pierre Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fplll/files/fplll-5.4.0-gcc11.patch21
-rw-r--r--sci-libs/fplll/fplll-5.4.0.ebuild4
2 files changed, 24 insertions, 1 deletions
diff --git a/sci-libs/fplll/files/fplll-5.4.0-gcc11.patch b/sci-libs/fplll/files/fplll-5.4.0-gcc11.patch
new file mode 100644
index 000000000000..935d342cda14
--- /dev/null
+++ b/sci-libs/fplll/files/fplll-5.4.0-gcc11.patch
@@ -0,0 +1,21 @@
+From 1d7dded000e425bb103841e68c79f81b335b7271 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Fran=C3=A7ois=20Bissey?= <frp.bissey@gmail.com>
+Date: Sat, 1 May 2021 08:19:41 +1200
+Subject: [PATCH] minimal change to compile with gcc-11
+
+---
+ fplll/enum/enumerate_ext_api.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/fplll/enum/enumerate_ext_api.h b/fplll/enum/enumerate_ext_api.h
+index 387a1461..803c870e 100644
+--- a/fplll/enum/enumerate_ext_api.h
++++ b/fplll/enum/enumerate_ext_api.h
+@@ -18,6 +18,7 @@
+ #define FPLLL_ENUMERATE_EXT_API_H
+
+ #include <array>
++#include <cstdint>
+ #include <functional>
+ #include <memory>
+
diff --git a/sci-libs/fplll/fplll-5.4.0.ebuild b/sci-libs/fplll/fplll-5.4.0.ebuild
index 1dbb837fc8b2..ecdf4079d976 100644
--- a/sci-libs/fplll/fplll-5.4.0.ebuild
+++ b/sci-libs/fplll/fplll-5.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ DEPEND="dev-libs/gmp:0
qd? ( sci-libs/qd )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${PN}-5.4.0-gcc11.patch" )
+
src_configure() {
econf \
$(use_with qd) \