summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 11:54:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-06 12:09:46 +0100
commit71c501b2822cffd4da67aa754925f7ce6d002288 (patch)
tree07caa3bf5b89a8730001eebd0c4511c45a35727e /sci-libs
parentsci-libs/voro++: EAPI-7 bump, use cmake.eclass, use GNUInstallDirs (diff)
downloadgentoo-71c501b2822cffd4da67aa754925f7ce6d002288.tar.gz
gentoo-71c501b2822cffd4da67aa754925f7ce6d002288.tar.bz2
gentoo-71c501b2822cffd4da67aa754925f7ce6d002288.zip
sci-libs/cminpack: 1.3.8 version bump, EAPI-7, cmake.eclass
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cminpack/Manifest1
-rw-r--r--sci-libs/cminpack/cminpack-1.3.8.ebuild35
-rw-r--r--sci-libs/cminpack/files/cminpack-1.3.8-cmake.patch10
3 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/cminpack/Manifest b/sci-libs/cminpack/Manifest
index cee1edd10f4c..1ddad5001fe4 100644
--- a/sci-libs/cminpack/Manifest
+++ b/sci-libs/cminpack/Manifest
@@ -1 +1,2 @@
DIST cminpack-1.3.5.tar.gz 312932 BLAKE2B 52ab91490f7c569e3931346510e08db55166322399736ceb9cc090a3be3624e8db6de12ed33ee8f97f6c5358dc2488f8aa7c7aab81365316f1dbb8948e669a2e SHA512 bb6f1764d90ccc7cbbb114a509f5416567246a730e4329617671e01b535b3a69f6a6df0483810ad1ad28228a1061a3595a15d437647b94a8a2013203905c6fed
+DIST cminpack-1.3.8.tar.gz 341494 BLAKE2B 5aebb220f9d5d1b314331a621d3717e4568eea6c37d0a70b935eda1fc0bec11d81b07c8951c8a8bfe5edd81e7878e138f8921d96a96c40230bfc423991e766be SHA512 0cab275074a31af69dbaf3ef6d41b20184c7cf9f33c78014a69ae7a022246fa79e7b4851341c6934ca1e749955b7e1096a40b4300a109ad64ebb1b2ea5d1d8ae
diff --git a/sci-libs/cminpack/cminpack-1.3.8.ebuild b/sci-libs/cminpack/cminpack-1.3.8.ebuild
new file mode 100644
index 000000000000..a32daf6c9510
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.3.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/"
+SRC_URI="https://github.com/devernay/cminpack/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="minpack"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RESTRICT="!test? ( test )"
+
+DOCS=( README.md readme.txt )
+
+PATCHES=( "${FILESDIR}"/${P}-cmake.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_BLAS=OFF # TODO: pick it up if you want to
+ -DCMINPACK_LIB_INSTALL_DIR=$(get_libdir)
+ -DBUILD_EXAMPLES=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( docs/. )
+ cmake_src_install
+}
diff --git a/sci-libs/cminpack/files/cminpack-1.3.8-cmake.patch b/sci-libs/cminpack/files/cminpack-1.3.8-cmake.patch
new file mode 100644
index 000000000000..92a9e777bbe5
--- /dev/null
+++ b/sci-libs/cminpack/files/cminpack-1.3.8-cmake.patch
@@ -0,0 +1,10 @@
+--- a/CMakeLists.txt 2021-02-10 06:05:42.000000000 +0100
++++ b/CMakeLists.txt 2021-03-06 11:51:15.594882519 +0100
+@@ -175,6 +175,6 @@
+
+ endforeach ()
+
+-install (EXPORT CMinpackConfig DESTINATION share/cminpack NAMESPACE cminpack::)
++install (EXPORT CMinpackConfig DESTINATION ${CMINPACK_LIB_INSTALL_DIR}/cmake/cminpack NAMESPACE cminpack::)
+
+ add_subdirectory (examples)