summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-05-31 12:56:53 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-05-31 12:56:53 +0200
commit926c98d2efbf6b5045463ece655adc62d52f5926 (patch)
tree42810dddc5235b539341f8301c08c5d910aa80ac /sci-libs
parentdev-python/werkzeug: Stabilize 2.1.2 ppc64, #848678 (diff)
downloadgentoo-926c98d2efbf6b5045463ece655adc62d52f5926.tar.gz
gentoo-926c98d2efbf6b5045463ece655adc62d52f5926.tar.bz2
gentoo-926c98d2efbf6b5045463ece655adc62d52f5926.zip
sci-libs/tensorpipe: add to tree
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/tensorpipe/Manifest1
-rw-r--r--sci-libs/tensorpipe/files/tensorpipe-2022.05.13-gentoo.patch10
-rw-r--r--sci-libs/tensorpipe/metadata.xml11
-rw-r--r--sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild30
4 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/tensorpipe/Manifest b/sci-libs/tensorpipe/Manifest
new file mode 100644
index 000000000000..088437c1b3f9
--- /dev/null
+++ b/sci-libs/tensorpipe/Manifest
@@ -0,0 +1 @@
+DIST tensorpipe-2022.05.13.tar.gz 259678 BLAKE2B 09231216b7ea1a5f4559bfd38d82337cdcde160c34ceb160c728b85ccf94566b812f0c38b6d3f6bc74b6f08b49b749939970265df343e3ca0214803f9d88e58c SHA512 cf0334f81affb2d844bc8b63c533a749753e36ee096f841641716a3bf044b17580262a2e9056d8d1351228e323c4f75401a2a120a5de397e80ec21a33fe56d2b
diff --git a/sci-libs/tensorpipe/files/tensorpipe-2022.05.13-gentoo.patch b/sci-libs/tensorpipe/files/tensorpipe-2022.05.13-gentoo.patch
new file mode 100644
index 000000000000..1d3ab0724030
--- /dev/null
+++ b/sci-libs/tensorpipe/files/tensorpipe-2022.05.13-gentoo.patch
@@ -0,0 +1,10 @@
+--- a/tensorpipe/CMakeLists.txt 2022-05-27 16:04:55.374134087 +0200
++++ b/tensorpipe/CMakeLists.txt 2022-05-27 16:05:11.596909345 +0200
+@@ -184,7 +184,6 @@
+ # We should keep libnop headers private as they should not be exposed to downstream users,
+ # but they're currently transitively included by tensorpipe/transport/connection.h (which
+ # is still unclear whether it should be a public or private header).
+-list(APPEND TP_INCLUDE_DIRS $<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/third_party/libnop/include>)
+
+
+ ## Target
diff --git a/sci-libs/tensorpipe/metadata.xml b/sci-libs/tensorpipe/metadata.xml
new file mode 100644
index 000000000000..a676d5dbb87a
--- /dev/null
+++ b/sci-libs/tensorpipe/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pytorch/tensorpipe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
new file mode 100644
index 000000000000..23422f9cc125
--- /dev/null
+++ b/sci-libs/tensorpipe/tensorpipe-2022.05.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+CommitId=bb1473a4b38b18268e8693044afdb8635bc8351b
+
+DESCRIPTION="provides a tensor-aware channel"
+HOMEPAGE="https://github.com/pytorch/tensorpipe/"
+SRC_URI="https://github.com/pytorch/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT=test
+
+RDEPEND="
+ dev-libs/libuv
+"
+DEPEND="${RDEPEND}
+ dev-libs/libnop
+"
+BDEPEND=""
+
+S="${WORKDIR}"/${PN}-${CommitId}
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )