summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-07 11:33:42 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-07 11:42:58 +0200
commita90e6fd96643573cafc031027366d6eff2c5b4c5 (patch)
tree84184af8b6f2a6e3820ec36e46600dcf2844f72c /sci-libs
parentsci-libs/ignition-math: migrate to cmake eclass (diff)
downloadgentoo-a90e6fd96643573cafc031027366d6eff2c5b4c5.tar.gz
gentoo-a90e6fd96643573cafc031027366d6eff2c5b4c5.tar.bz2
gentoo-a90e6fd96643573cafc031027366d6eff2c5b4c5.zip
sci-libs/ignition-math: bump to 6.5.0
Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ignition-math/Manifest1
-rw-r--r--sci-libs/ignition-math/ignition-math-6.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sci-libs/ignition-math/Manifest b/sci-libs/ignition-math/Manifest
index 101617f61906..662132fa99c6 100644
--- a/sci-libs/ignition-math/Manifest
+++ b/sci-libs/ignition-math/Manifest
@@ -1,2 +1,3 @@
DIST ignition-math4_4.0.0.tar.bz2 387717 BLAKE2B 1b19bcd377eb18b616a300e022419ba2651795e04c0f0a3769f565e6febdc1a37f321c81730e1c13c9f9b17f35e6cf558d1129b278b2477ec8d5a5f46b927d66 SHA512 4815c6222945fd228b2d23c9da7ad8876f8ba1fea382312e1eb320819ec5d8bbf637095c18dbe2413184bbea77040bd1a5492ea9427355fc5e62f6169277530e
DIST ignition-math6_6.4.0.tar.gz 515870 BLAKE2B d975edfa2e23560784adef1d66e7613c822a65bcc8b20d33aa030a570fdf3b19043eb6750e93728f2ff5e8ee14ab047a1420bf9991ea6519ec7399235e262ba1 SHA512 8a6e672ef6de591d25200f288deaaa16cc43e3c90804ee5ead0f06345036afbfa40acb531eb5b6a1fa80bd34c0c5964662cc0659d8bed2c811ad7c776d6f77cb
+DIST ignition-math6_6.5.0.tar.gz 539313 BLAKE2B 0ec7b5a4e8eac4161fd2df607c18f905bbfb12923373e2c74e435da8cd98926feac7e6b5434f7a335888a273757786872cc7cc3d0dd4f1e342a5ce488f07420d SHA512 ea8702339ffa1a76bb8aded17c83a620568edec472bf0722997a7f907ed07ead0d2e89356055835f9ee6dcc462066bdbc67cf07c01e0efe4e1b8fb3e4d2407fa
diff --git a/sci-libs/ignition-math/ignition-math-6.5.0.ebuild b/sci-libs/ignition-math/ignition-math-6.5.0.ebuild
new file mode 100644
index 000000000000..ab724f9e7b7c
--- /dev/null
+++ b/sci-libs/ignition-math/ignition-math-6.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=RelWithDebInfo
+inherit cmake vcs-snapshot
+
+DESCRIPTION="A small, fast, and high performance math library for robot applications"
+HOMEPAGE="https://ignitionrobotics.org/libraries/math"
+SRC_URI="https://github.com/ignitionrobotics/ign-math/archive/${PN}6_${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="6/6"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3
+ dev-util/ignition-cmake:2"
+BDEPEND="
+ dev-util/ignition-cmake:2"
+
+S="${WORKDIR}/${PN}6_${PV}"
+PATCHES=( "${FILESDIR}/includes.patch" )