summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-06-25 22:36:55 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-06-25 22:36:55 -0500
commitb4796e3f7a134820c39501afe6abcee8c9c9b701 (patch)
tree3c350e49beed989c31d3d36c88dfa5986779d025 /sci-libs
parentsci-libs/dealii: build with c++17 support (diff)
downloadgentoo-b4796e3f7a134820c39501afe6abcee8c9c9b701.tar.gz
gentoo-b4796e3f7a134820c39501afe6abcee8c9c9b701.tar.bz2
gentoo-b4796e3f7a134820c39501afe6abcee8c9c9b701.zip
sci-libs/dealii: build with c++17 support the right way...
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dealii/dealii-9.4.0.ebuild6
-rw-r--r--sci-libs/dealii/dealii-9999.ebuild6
2 files changed, 10 insertions, 2 deletions
diff --git a/sci-libs/dealii/dealii-9.4.0.ebuild b/sci-libs/dealii/dealii-9.4.0.ebuild
index 2c2a3de2ae5c..b493d369767a 100644
--- a/sci-libs/dealii/dealii-9.4.0.ebuild
+++ b/sci-libs/dealii/dealii-9.4.0.ebuild
@@ -103,7 +103,6 @@ src_configure() {
-DDEAL_II_WITH_ARPACK="$(usex arpack)"
-DDEAL_II_WITH_CGAL="$(usex cgal)"
-DDEAL_II_WITH_CUDA="$(usex cuda)"
- -DDEAL_II_WITH_CXX17=ON
-DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
-DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
-DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
@@ -148,6 +147,11 @@ src_configure() {
append-cxxflags "-msse2"
fi
+ # Unconditionally enable strict C++17 standard. This is necessary for
+ # USE=cgal and USE=kokkos and safe to set for all presently supported
+ # compilers
+ append-cxxflags "-std=c++17"
+
cmake_src_configure
}
diff --git a/sci-libs/dealii/dealii-9999.ebuild b/sci-libs/dealii/dealii-9999.ebuild
index 2c2a3de2ae5c..b493d369767a 100644
--- a/sci-libs/dealii/dealii-9999.ebuild
+++ b/sci-libs/dealii/dealii-9999.ebuild
@@ -103,7 +103,6 @@ src_configure() {
-DDEAL_II_WITH_ARPACK="$(usex arpack)"
-DDEAL_II_WITH_CGAL="$(usex cgal)"
-DDEAL_II_WITH_CUDA="$(usex cuda)"
- -DDEAL_II_WITH_CXX17=ON
-DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
-DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
-DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
@@ -148,6 +147,11 @@ src_configure() {
append-cxxflags "-msse2"
fi
+ # Unconditionally enable strict C++17 standard. This is necessary for
+ # USE=cgal and USE=kokkos and safe to set for all presently supported
+ # compilers
+ append-cxxflags "-std=c++17"
+
cmake_src_configure
}