summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2021-06-08 09:34:50 +0800
committerYixun Lan <dlan@gentoo.org>2021-06-08 10:22:55 +0800
commitbccd13e128ae7138f84d61f408f4f734e32a3c67 (patch)
tree1ff70e9ed13d627d5636fc084e178499c15a41dd /sci-libs
parentdev-libs/libxml2: add upstream patch for PHP/HTML serialisation regression (diff)
downloadgentoo-bccd13e128ae7138f84d61f408f4f734e32a3c67.tar.gz
gentoo-bccd13e128ae7138f84d61f408f4f734e32a3c67.tar.bz2
gentoo-bccd13e128ae7138f84d61f408f4f734e32a3c67.zip
sci-libs/fftw: fix two lib path issue for ARCH=riscv
thanks @soap for helping this Closes: https://bugs.gentoo.org/794208 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/fftw-3.3.9.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/sci-libs/fftw/fftw-3.3.9.ebuild b/sci-libs/fftw/fftw-3.3.9.ebuild
index 32ce75db90af..cb50c0ff6875 100644
--- a/sci-libs/fftw/fftw-3.3.9.ebuild
+++ b/sci-libs/fftw/fftw-3.3.9.ebuild
@@ -147,13 +147,16 @@ src_install() {
rm -r "${ED}"/usr/share/doc/${PF}/html || die
fi
- local x
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- local u
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_${u} &|" "$x" > "${x%.pc}_${u}.pc" || die
+ augment_pc_files() {
+ local x
+ for x in "${ED}"/usr/$(get_libdir)/pkgconfig/*.pc; do
+ local u
+ for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
+ sed -e "s|-lfftw3[flq]\?|&_${u} &|" "${x}" > "${x%.pc}_${u}.pc" || die
+ done
done
- done
+ }
+ multilib_foreach_abi augment_pc_files
# fftw uses pkg-config to record its private dependencies
find "${ED}" -name '*.la' -delete || die