summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-06-05 21:38:36 -0400
committerRick Farina <zerochaos@gentoo.org>2021-06-05 21:38:36 -0400
commitc1907f9a9239d34fe031153ec3d0908399dc0cab (patch)
treee6f7bd1628989b13ef8efbc80359f0baaa487270 /sci-libs
parentgames-engines/openmw: 0.46 requires OSG 3.4 (diff)
downloadgentoo-c1907f9a9239d34fe031153ec3d0908399dc0cab.tar.gz
gentoo-c1907f9a9239d34fe031153ec3d0908399dc0cab.tar.bz2
gentoo-c1907f9a9239d34fe031153ec3d0908399dc0cab.zip
sci-libs/volk: bump
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/volk/Manifest1
-rw-r--r--sci-libs/volk/volk-2.5.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/volk/Manifest b/sci-libs/volk/Manifest
index 1311005993ad..a7e2357d1ec2 100644
--- a/sci-libs/volk/Manifest
+++ b/sci-libs/volk/Manifest
@@ -1 +1,2 @@
DIST volk-2.4.1.tar.xz 315072 BLAKE2B 1ce1d220f9e1e9251332fb6caf7d72eaf3db85009a49434edbf6490b02ab016c4b1eb8677f0e5f446f5783615f2256710621b1806684dffeb1ff441756e4a635 SHA512 7c16a5d750cdea2927c3b08dcad29e19f10932a3b7b35cb25ecc66554d7e441c95906a4746fcf62f895709aee1191f1bb91189c3509b444b6b4ba37a306f9909
+DIST volk-2.5.0.tar.xz 322280 BLAKE2B edbf0f7ffecf08e8f0d8ebbb85a9bc943286c5d022442d0d7e480be4ecbd696a8b2e87e4d16d7133467b429e4894a1d166c534b5a05630cb313906aed8476cfe SHA512 94e5af925d6b6e157445ca80c2ba47a92f5ee681716d2a70a5519caa30a603b3f31a9f1ccbd14ef65349645b56a3f406b4aa1f354c322be60bd76d646a4850c6
diff --git a/sci-libs/volk/volk-2.5.0.ebuild b/sci-libs/volk/volk-2.5.0.ebuild
new file mode 100644
index 000000000000..aff22b50715c
--- /dev/null
+++ b/sci-libs/volk/volk-2.5.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+#https://github.com/gnuradio/volk/issues/383
+CMAKE_BUILD_TYPE="None"
+inherit cmake python-single-r1
+
+DESCRIPTION="vector optimized library of kernels"
+HOMEPAGE="http://libvolk.org"
+SRC_URI="https://github.com/gnuradio/volk/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="orc test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RDEPEND="${PYTHON_DEPS}
+ !<net-wireless/gnuradio-3.8
+ dev-libs/boost:=
+ orc? ( dev-lang/orc )"
+DEPEND="${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]')"
+
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ORC=$(usex orc)
+ -DPYTHON_EXECUTABLE="${PYTHON}"
+ -DENABLE_TESTING="$(usex test)"
+ -DENABLE_PROFILING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}