summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2022-06-25 22:17:37 -0500
committerMatthias Maier <tamiko@gentoo.org>2022-06-25 22:32:09 -0500
commitc84e74a3b989e9b386b26a181e18e69276915eee (patch)
tree2beaff932e2a18d7d0eae75aba3e3bdf28de019b /sci-libs
parentsci-libs/tensorflow: add 2.9.0 (diff)
downloadgentoo-c84e74a3b989e9b386b26a181e18e69276915eee.tar.gz
gentoo-c84e74a3b989e9b386b26a181e18e69276915eee.tar.bz2
gentoo-c84e74a3b989e9b386b26a181e18e69276915eee.zip
sci-libs/dealii: add 9.4.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dealii/Manifest2
-rw-r--r--sci-libs/dealii/dealii-9.4.0.ebuild166
-rw-r--r--sci-libs/dealii/metadata.xml2
3 files changed, 170 insertions, 0 deletions
diff --git a/sci-libs/dealii/Manifest b/sci-libs/dealii/Manifest
index f3f2ba99e10a..94a0d4e45df5 100644
--- a/sci-libs/dealii/Manifest
+++ b/sci-libs/dealii/Manifest
@@ -2,3 +2,5 @@ DIST dealii-9.3.1-offline_documentation.tar.gz 342389060 BLAKE2B 71b47816dd22f49
DIST dealii-9.3.1.tar.gz 24459280 BLAKE2B c7f1d461017da24efd6f3247217fd1b889e0cbf2ac62c3fd305e03aed90d5ba82b58ceb84d34a84608b833b734e12abc77a63693aaa6eed767b4f5f157233ba0 SHA512 c3ba3e16fa4792bb4f3e85163e67b08271c84faff72c49b858a955851401adf2499e278790803061a61c4024964f6da3f0ef7b09c0370d8d0b5af16b7c3bdaef
DIST dealii-9.3.3-offline_documentation.tar.gz 346914833 BLAKE2B 8a3661f44aef70c25837fca67175e410f1404991a5fa3698d2e732f1ae045f987a3d9c2fb21294de32768533968e94178f7537f2c3221afdb427fb10478257b5 SHA512 05d8c9573e8277c88f81ff318d295b099e2241c5358cc243eaae35044703a8abc8cac7b7b8049b3527d167f60b11820bd8418fde2e6a6929c03abbf6cc5b6658
DIST dealii-9.3.3.tar.gz 24462944 BLAKE2B 581a8c618fab96127ac95fe9ba5ea5410eb6f9193ce96b6a0d8d28dd125689fb11868115ae8163b7e223970321ddd75347ea21568ea1cdc1e783f94506f00d91 SHA512 31a05a2f539dd2336683c2ab887fef47f08a5127fe23163128036f3143c0c77dca08004b014704e1c7cc07d7578458636715dcbefd654e5fc4511d6d315b604d
+DIST dealii-9.4.0-offline_documentation.tar.gz 390747598 BLAKE2B 6e8ed938b31a9e6bbbdd5baacce056edc31d489ecd3e9528283650f431d004ca122c968567fe342744d52bab8f8be53ab1b20d56636e2dc48f8cf551791a08bd SHA512 703eb50150ae5bd77f0d84271babd50483c3a9b069abb5b7e8827d00efaa5d189a43ac54f0ef8b2f746b12a10dc611669f5fddd655241a66af4915ec1d458185
+DIST dealii-9.4.0.tar.gz 30297914 BLAKE2B 6beb4c7b83f5316e703d4b77340900c376e622b1dc59c9058a8927174a8c6991994957588b6adf88238e72eec93f8941bfbfb2d0bb01070560468d051d9829f8 SHA512 3be740fbabff65a18870496f483ac4ed6d35c8a53b5128dd09b2dfabe82d60e4a75f02fd508b44f6c93805999aab98f551154f10ca2ad5fabede65c2d6dce320
diff --git a/sci-libs/dealii/dealii-9.4.0.ebuild b/sci-libs/dealii/dealii-9.4.0.ebuild
new file mode 100644
index 000000000000..05e4e7dd00ec
--- /dev/null
+++ b/sci-libs/dealii/dealii-9.4.0.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# deal.II uses its own FindLAPACK.cmake file that calls into the system
+# FindLAPACK.cmake module and does additional internal setup. Do not remove
+# any of these modules:
+CMAKE_REMOVE_MODULES_LIST=""
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Solving partial differential equations with the finite element method"
+HOMEPAGE="https://www.dealii.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dealii/dealii.git"
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz
+ doc? (
+ https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}-offline_documentation.tar.gz
+ )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="
+ adolc arborx assimp arpack cgal cpu_flags_x86_avx cpu_flags_x86_avx512f
+ cpu_flags_x86_sse2 cuda +debug doc +examples ginkgo gmsh +gsl hdf5
+ +lapack metis mpi muparser opencascade p4est petsc scalapack slepc
+ +sparse static-libs sundials symengine trilinos
+"
+
+# TODO: add slepc use flag once slepc is packaged for gentoo-science
+REQUIRED_USE="
+ arborx? ( trilinos )
+ p4est? ( mpi )
+ slepc? ( petsc )
+ trilinos? ( mpi )"
+
+RDEPEND="dev-libs/boost:=
+ app-arch/bzip2
+ sys-libs/zlib
+ dev-cpp/tbb:=
+ arborx? ( sci-libs/arborx[mpi=] )
+ adolc? ( sci-libs/adolc )
+ arpack? ( sci-libs/arpack[mpi=] )
+ assimp? ( media-libs/assimp:= )
+ cuda? ( dev-util/nvidia-cuda-toolkit )
+ ginkgo? ( sci-libs/ginkgo )
+ gmsh? ( sci-libs/gmsh )
+ gsl? ( sci-libs/gsl:= )
+ hdf5? ( sci-libs/hdf5[mpi=] )
+ lapack? ( virtual/lapack )
+ metis? (
+ >=sci-libs/metis-5
+ mpi? ( >=sci-libs/parmetis-4 )
+ )
+ mpi? ( virtual/mpi[cxx] )
+ muparser? ( dev-cpp/muParser )
+ opencascade? ( sci-libs/opencascade:= )
+ p4est? ( sci-libs/p4est[mpi] )
+ petsc? ( sci-mathematics/petsc[mpi=] )
+ scalapack? ( sci-libs/scalapack )
+ slepc? ( sci-mathematics/slepc[mpi=] )
+ sparse? ( sci-libs/umfpack )
+ sundials? ( sci-libs/sundials:= )
+ symengine? ( >=sci-libs/symengine-0.4:= )
+ trilinos? ( sci-libs/trilinos )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] dev-lang/perl )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.1.1-no-ld-flags.patch
+)
+
+src_configure() {
+ # deal.II needs a custom build type:
+ local CMAKE_BUILD_TYPE=$(usex debug DebugRelease Release)
+
+ local mycmakeargs=(
+ -DDEAL_II_PACKAGE_VERSION="${PV}"
+ -DCMAKE_INSTALL_RPATH_USE_LINK_PATH=OFF
+ -DDEAL_II_ALLOW_AUTODETECTION=OFF
+ -DDEAL_II_ALLOW_BUNDLED=OFF
+ -DDEAL_II_ALLOW_PLATFORM_INTROSPECTION=OFF
+ -DDEAL_II_COMPILE_EXAMPLES=OFF
+ -DDEAL_II_DOCHTML_RELDIR="share/doc/${P}/html"
+ -DDEAL_II_DOCREADME_RELDIR="share/doc/${P}"
+ -DDEAL_II_COMPILE_EXAMPLES=OFF
+ -DDEAL_II_EXAMPLES_RELDIR="share/doc/${P}/examples"
+ -DDEAL_II_LIBRARY_RELDIR="$(get_libdir)"
+ -DDEAL_II_SHARE_RELDIR="share/${PN}"
+ -DDEAL_II_WITH_ZLIB=ON
+ -DDEAL_II_WITH_ADOLC="$(usex adolc)"
+ -DDEAL_II_WITH_ARBORX="$(usex arborx)"
+ -DDEAL_II_WITH_ASSIMP="$(usex assimp)"
+ -DDEAL_II_WITH_ARPACK="$(usex arpack)"
+ -DDEAL_II_WITH_CGAL="$(usex cgal)"
+ -DDEAL_II_WITH_CUDA="$(usex cuda)"
+ -DDEAL_II_WITH_GINKGO="$(usex ginkgo)"
+ -DDEAL_II_COMPONENT_DOCUMENTATION="$(usex doc)"
+ -DDEAL_II_COMPONENT_EXAMPLES="$(usex examples)"
+ -DDEAL_II_WITH_GMSH="$(usex gmsh)"
+ -DDEAL_II_WITH_GSL="$(usex gsl)"
+ -DDEAL_II_WITH_HDF5="$(usex hdf5)"
+ -DDEAL_II_WITH_KOKKOS="$(usex trilinos)"
+ -DDEAL_II_WITH_LAPACK="$(usex lapack)"
+ -DDEAL_II_WITH_METIS="$(usex metis)"
+ -DDEAL_II_WITH_MPI="$(usex mpi)"
+ -DDEAL_II_WITH_MUPARSER="$(usex muparser)"
+ -DDEAL_II_WITH_OPENCASCADE="$(usex opencascade)"
+ -DDEAL_II_WITH_P4EST="$(usex p4est)"
+ -DDEAL_II_WITH_PETSC="$(usex petsc)"
+ -DDEAL_II_WITH_SCALAPACK="$(usex scalapack)"
+ -DDEAL_II_WITH_SLEPC="$(usex slepc)"
+ -DDEAL_II_WITH_SUNDIALS="$(usex sundials)"
+ -DDEAL_II_WITH_SYMENGINE="$(usex symengine)"
+ -DDEAL_II_WITH_UMFPACK="$(usex sparse)"
+ -DBUILD_SHARED_LIBS="$(usex !static-libs)"
+ -DDEAL_II_PREFER_STATIC_LIBS="$(usex static-libs)"
+ -DDEAL_II_WITH_TBB=ON
+ -DDEAL_II_WITH_TRILINOS="$(usex trilinos)"
+ )
+
+ use opencascade && mycmakeargs+=(
+ -DCMAKE_PREFIX_PATH="/usr/$(get_libdir)/opencascade"
+ )
+
+ # Do a little dance for purely cosmetic QA reasons. The build system
+ # does query for the highest instruction set first and skips the other
+ # variables if a "higher" variant is set
+ if use cpu_flags_x86_avx512f; then
+ mycmakeargs+=( -DDEAL_II_HAVE_AVX512=yes )
+ append-cxxflags "-mavx512f"
+ elif use cpu_flags_x86_avx; then
+ mycmakeargs+=( -DDEAL_II_HAVE_AVX=yes )
+ append-cxxflags "-mavx2"
+ elif use cpu_flags_x86_avx; then
+ mycmakeargs+=( -DDEAL_II_HAVE_SSE2=yes )
+ append-cxxflags "-msse2"
+ fi
+
+ cmake_src_configure
+}
+
+src_install() {
+ if use doc && [[ ${PV} != *9999* ]]; then
+ # copy missing images to the build directory:
+ cp -r "${WORKDIR}"/doc/doxygen/deal.II/images \
+ "${BUILD_DIR}"/doc/doxygen/deal.II || die
+ # replace links:
+ sed -i \
+ 's#"http://www.dealii.org/images/steps/developer/\(step-.*\)"#"images/\1"#g' \
+ "${BUILD_DIR}"/doc/doxygen/deal.II/step_*.html || die "sed failed"
+ fi
+ cmake_src_install
+
+ # decompress the installed example sources:
+ use examples && docompress -x /usr/share/doc/${PF}/examples
+}
diff --git a/sci-libs/dealii/metadata.xml b/sci-libs/dealii/metadata.xml
index 8b4433d57a7d..c25ce26eaf2c 100644
--- a/sci-libs/dealii/metadata.xml
+++ b/sci-libs/dealii/metadata.xml
@@ -17,7 +17,9 @@ to the complex data structures and algorithms required.
</longdescription>
<use>
<flag name="adolc">Adds support for ADOL-C (<pkg>sci-libs/adolc</pkg>)</flag>
+ <flag name="arborx">Adds support for ARBORX (<pkg>sci-libs/arborx</pkg>)</flag>
<flag name="arpack">Adds support for ARPACK (<pkg>sci-libs/arpack</pkg>)</flag>
+ <flag name="cgal">Adds support for CGAL (<pkg>sci-mathematics/cgal</pkg>)</flag>
<flag name="debug">
Build an additional debug library with extra debug codepaths, like asserts
and extra output. If you want to get meaningful backtraces see