summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-02-26 14:37:14 -0500
committerSam James <sam@gentoo.org>2021-02-27 03:06:43 +0000
commitca92672a0c280c20cbca4b344f871610b662c863 (patch)
tree268602a1f565da5aa2f9ea97d492ef9724278545 /sci-libs
parentsci-libs/coinor-cppad: bump to 20210000.5, ported to EAPI 7 + cmake (diff)
downloadgentoo-ca92672a0c280c20cbca4b344f871610b662c863.tar.gz
gentoo-ca92672a0c280c20cbca4b344f871610b662c863.tar.bz2
gentoo-ca92672a0c280c20cbca4b344f871610b662c863.zip
sci-libs/coinor-cppad: remove old
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/coinor-cppad/Manifest1
-rw-r--r--sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild59
-rw-r--r--sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch79
-rw-r--r--sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch215
4 files changed, 0 insertions, 354 deletions
diff --git a/sci-libs/coinor-cppad/Manifest b/sci-libs/coinor-cppad/Manifest
index 16ecbbb85d38..51f68ba13643 100644
--- a/sci-libs/coinor-cppad/Manifest
+++ b/sci-libs/coinor-cppad/Manifest
@@ -1,2 +1 @@
DIST coinor-cppad-20210000.5.tar.gz 1663397 BLAKE2B 3ce4f5733641fac16ac00b6e49cb74e2237502eac32f592190491ddd5dcb8a41f340c1eed8529dbdecb343f7a791d4fc5ddc1e21ce9f9706f28608ac3a5e965a SHA512 40cbe8dc32af9bb3b92cdd4c81e6f75424ece701df9251d4c63652998ca4cb8d50057e190a16e51333d168299f33ff2353074fa7f24f2cec29f68db53f6ae17c
-DIST cppad-20140519.gpl.tgz 2208236 BLAKE2B 5d53891ef3b458c3914f5d59f6656290be2811fbc84ca3f9bd253ce4620b1a4b00397e1beed694cdc5284a1f74441b68520b861c90d158c4eee11d1f8927b362 SHA512 8f47e545bc76f66edccb9ea083ddebcb5852fa1807d727b6e1f445ca74731e74f7614a1d33b48c6eafbc5129b319e513594b415ee838bdc634f9c00a6d9a22af
diff --git a/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild b/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild
deleted file mode 100644
index 537f051053f1..000000000000
--- a/sci-libs/coinor-cppad/coinor-cppad-20140519-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-AUTOTOOLS_AUTORECONF=yes
-
-inherit autotools-utils multilib
-
-MYP=cppad-${PV}
-
-DESCRIPTION="COIN-OR C++ Algorithmic Differentiation"
-HOMEPAGE="https://projects.coin-or.org/CppAD/"
-SRC_URI="http://www.coin-or.org/download/source/CppAD/${MYP}.gpl.tgz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- dev-libs/boost[threads]
- sci-libs/adolc:0=
- sci-libs/ipopt:0="
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-dash.patch
- "${FILESDIR}"/${P}-boost.patch
- )
-
-src_configure() {
- local myeconfargs=( $(use doc Documentation) )
- autotools-utils_src_configure CXX_FLAGS="${CXXFLAGS}"
-}
-
-src_compile() {
- autotools-utils_src_compile
- if use doc; then
- ./build.sh doxygen || die
- fi
-}
-
-src_test() {
- autotools-utils_src_test check test
-}
-
-src_install() {
- use doc && HTML_DOC=( "${BUILD_DIR}"/doxydocs/html/. )
- autotools-utils_src_install
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r example/*
- fi
-}
diff --git a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch
deleted file mode 100644
index 7a4d3ae83aca..000000000000
--- a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-boost.patch
+++ /dev/null
@@ -1,79 +0,0 @@
- configure.ac | 18 ++++++++++--------
- 1 file changed, 10 insertions(+), 8 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 033621f..87e129a 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -550,13 +550,14 @@ dnl check for boost thread library
- AC_LANG_PUSH([C++])
- LDFLAGS_save=$LDFLAGS
- CXXFLAGS_save=$CXXFLAGS
-+LIBS_save=$LIBS
- boost_thread_found='no'
- if test "$BOOST_DIR" != '' ; then
- CXXFLAGS="-I$BOOST_DIR/include $CXXFLAGS"
- fi
- if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
-- bthread_lib='-lboost_thread-mt'
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ bthread_lib='-lboost_thread-mt -lboost_system'
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -568,7 +569,7 @@ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
- fi
- if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.so"
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -580,7 +581,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- fi
- if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.a"
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -591,8 +592,8 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- )
- fi
- if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
-- bthread_lib='-lboost_thread'
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ bthread_lib='-lboost_thread -lboost_system'
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -604,7 +605,7 @@ if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
- fi
- if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread.so"
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -616,7 +617,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- fi
- if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread.a"
-- LDFLAGS="$LDFLAGS_save $bthread_lib"
-+ LIBS="$LIBS_save $bthread_lib"
- AC_LINK_IFELSE(
- [AC_LANG_PROGRAM(
- [# include <boost/thread.hpp>],
-@@ -636,6 +637,7 @@ else
- fi
- LDFLAGS=$LDFLAGS_save
- CXXFLAGS=$CXXFLAGS_save
-+LIBS=$LIBS_save
- AC_LANG_POP([C++])
- #
- dnl --------------------------------------------------------------------------
diff --git a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch b/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch
deleted file mode 100644
index fe0b210f1075..000000000000
--- a/sci-libs/coinor-cppad/files/coinor-cppad-20140519-dash.patch
+++ /dev/null
@@ -1,215 +0,0 @@
- configure.ac | 56 ++++++++++++++++++++++++++++----------------------------
- 1 file changed, 28 insertions(+), 28 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 9e917dd..033621f 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -194,7 +194,7 @@ AC_ARG_WITH(sparse_list,
- )
- AC_MSG_RESULT([$sparse_list])
- if test "$sparse_set" = "yes" ; then
-- if test "$sparse_list" == "yes" ; then
-+ if test "$sparse_list" = "yes" ; then
- AC_MSG_ERROR([cannot --with both sparse_set and sparse_list])
- fi
- AC_SUBST(cppad_internal_sparse_set, sparse_set)
-@@ -374,7 +374,7 @@ AC_SUBST(cppad_max_num_threads, [$max_num_threads])
- dnl type used for addresses in AD tapes [ default = unsigned int ] -----------
- AC_MSG_CHECKING([TAPE_ADDR_TYPE])
- AC_ARG_VAR(TAPE_ADDR_TYPE, [type used for addresses in AD tapes])
--if test "$TAPE_ADDR_TYPE" == "" ; then
-+if test "$TAPE_ADDR_TYPE" = "" ; then
- addr_t="unsigned int"
- else
- addr_t="$TAPE_ADDR_TYPE"
-@@ -382,22 +382,22 @@ fi
- AC_SUBST(cppad_tape_addr_type, [$addr_t])
- AC_MSG_RESULT([$addr_t])
- ok="no"
--if test "$addr_t" == "size_t" ; then
-+if test "$addr_t" = "size_t" ; then
- ok="yes"
- fi
--if test "$addr_t" == "int" ; then
-+if test "$addr_t" = "int" ; then
- AC_MSG_WARN(
- [TAPE_ADDR_TYPE=int is for CppAD developers (not users)]
- )
- ok="yes"
- fi
--if test "$addr_t" == "unsigned int" ; then
-+if test "$addr_t" = "unsigned int" ; then
- ok="yes"
- fi
--if test "$addr_t" == "unsigned short int" ; then
-+if test "$addr_t" = "unsigned short int" ; then
- ok="yes"
- fi
--if test "$ok" == "no" ; then
-+if test "$ok" = "no" ; then
- AC_MSG_ERROR(
- [$addr_t is not a valid choice for TAPE_ADDR_TYPE]
- )
-@@ -406,7 +406,7 @@ fi
- dnl type used for tape identifier [ default = unsigned int ] -----------
- AC_MSG_CHECKING([TAPE_ID_TYPE])
- AC_ARG_VAR(TAPE_ID_TYPE, [type used for addresses in AD tapes])
--if test "$TAPE_ID_TYPE" == "" ; then
-+if test "$TAPE_ID_TYPE" = "" ; then
- tape_id_t="unsigned int"
- else
- tape_id_t="$TAPE_ID_TYPE"
-@@ -414,22 +414,22 @@ fi
- AC_SUBST(cppad_tape_id_type, [$tape_id_t])
- AC_MSG_RESULT([$tape_id_t])
- ok="no"
--if test "$tape_id_t" == "size_t" ; then
-+if test "$tape_id_t" = "size_t" ; then
- ok="yes"
- fi
--if test "$tape_id_t" == "int" ; then
-+if test "$tape_id_t" = "int" ; then
- AC_MSG_WARN(
- [TAPE_ID_TYPE=int is for CppAD developers (not users)]
- )
- ok="yes"
- fi
--if test "$tape_id_t" == "unsigned int" ; then
-+if test "$tape_id_t" = "unsigned int" ; then
- ok="yes"
- fi
--if test "$tape_id_t" == "unsigned short int" ; then
-+if test "$tape_id_t" = "unsigned short int" ; then
- ok="yes"
- fi
--if test "$ok" == "no" ; then
-+if test "$ok" = "no" ; then
- AC_MSG_ERROR(
- [$tape_id_t is not a valid choice for TAPE_ID_TYPE]
- )
-@@ -447,7 +447,7 @@ AC_SUBST(cppad_has_rvalue, 0)
- dnl Determine if size_t has same size as unsigned int
- AC_CHECK_SIZEOF([size_t])
- AC_CHECK_SIZEOF([unsigned int])
--if test "$ac_cv_size_t" == "$ac_cv_unsigned_int" ; then
-+if test "$ac_cv_size_t" = "$ac_cv_unsigned_int" ; then
- AC_SUBST(cppad_size_t_same_unsigned_int, 1)
- else
- AC_SUBST(cppad_size_t_same_unsigned_int, 0)
-@@ -485,8 +485,8 @@ AC_PROG_RANLIB
- dnl AC_PROG_CXX([compiler-search-list]) outputs CXX as C++ compiler to use
- AC_PROG_CXX
- AC_MSG_CHECKING([whether using Microsoft C++ compiler])
--AM_CONDITIONAL(CppAD_MS_COMPILER, test "$CXX" == "cl" || test "$CXX" == "icl")
--if test "$CXX" == "cl" || test "$CXX" == "icl"; then
-+AM_CONDITIONAL(CppAD_MS_COMPILER, test "$CXX" = "cl" || test "$CXX" = "icl")
-+if test "$CXX" = "cl" || test "$CXX" = "icl"; then
- AC_MSG_RESULT([yes])
- else
- AC_MSG_RESULT([no])
-@@ -531,7 +531,7 @@ AC_CHECK_LIB(
- [pthread="no"]
- )
- AM_CONDITIONAL(CppAD_PTHREAD, test "$pthread" = "yes")
--if test "$pthread" == "yes" ; then
-+if test "$pthread" = "yes" ; then
- AC_SUBST(PTHREAD_LIB,"-lpthread")
- else
- AC_SUBST(PTHREAD_LIB,"")
-@@ -554,7 +554,7 @@ boost_thread_found='no'
- if test "$BOOST_DIR" != '' ; then
- CXXFLAGS="-I$BOOST_DIR/include $CXXFLAGS"
- fi
--if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib='-lboost_thread-mt'
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -566,7 +566,7 @@ if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
- [boost_thread_found='no']
- )
- fi
--if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.so"
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -578,7 +578,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
- [boost_thread_found='no']
- )
- fi
--if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread-mt.a"
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -590,7 +590,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
- [boost_thread_found='no']
- )
- fi
--if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" = '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib='-lboost_thread'
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -602,7 +602,7 @@ if test "$BOOST_DIR" == '' && test "$boost_thread_found" == 'no' ; then
- [boost_thread_found='no']
- )
- fi
--if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread.so"
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -614,7 +614,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
- [boost_thread_found='no']
- )
- fi
--if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
-+if test "$BOOST_DIR" != '' && test "$boost_thread_found" = 'no' ; then
- bthread_lib="$BOOST_DIR/lib/libboost_thread.a"
- LDFLAGS="$LDFLAGS_save $bthread_lib"
- AC_LINK_IFELSE(
-@@ -627,7 +627,7 @@ if test "$BOOST_DIR" != '' && test "$boost_thread_found" == 'no' ; then
- )
- fi
- AM_CONDITIONAL(CppAD_BTHREAD, test "$boost_thread_found" = 'yes')
--if test "$boost_thread_found" == 'yes' ; then
-+if test "$boost_thread_found" = 'yes' ; then
- AC_SUBST(BTHREAD_LIB,"$bthread_lib")
- AC_MSG_RESULT([boost::thread library... yes])
- else
-@@ -650,12 +650,12 @@ fi
- AC_SUBST(CPPAD_IPOPT_LD_PATH, "$IPOPT_LD_PATH")
- #
- AC_SUBST(CPPAD_IPOPT_LIBS, "$IPOPT_LIBS -lipopt")
--if test "$have_pkg_config" == "yes"; then
-+if test "$have_pkg_config" = "yes"; then
- dnl set CPPAD_IPOPT_LIBS
- PKG_CONFIG_PATH="$IPOPT_DIR/lib/pkgconfig:$IPOPT_DIR/share/pkgconfig"
- PKG_CONFIG_PATH="$PKG_CONFIG_PATH:$IPOPT_DIR/lib64/pkgconfig"
- export PKG_CONFIG_PATH
-- if pkg-config --libs ipopt >& /dev/null ; then
-+ if pkg-config --libs ipopt > /dev/null 2>&1 ; then
- CPPAD_IPOPT_LIBS=`pkg-config --libs ipopt`
- else
- dnl check for blas library
-@@ -696,7 +696,7 @@ dnl
- AC_SUBST(cppad_description, "Differentiation of C++ Algorithms")
- AC_SUBST(cppad_version, ${PACKAGE_VERSION} )
- AC_SUBST(cppad_url, "http://www.coin-or.org/CppAD")
--if test "$prefix" == "NONE" ; then
-+if test "$prefix" = "NONE" ; then
- cppad_cflags_value="-I$HOME/include"
- cppad_libs_value="-L$HOME/lib"
- else
-@@ -707,7 +707,7 @@ if test "$POSTFIX_DIR" != "" ; then
- cppad_cflags_value="$cppad_cflags_value/$POSTFIX_DIR"
- cppad_libs_value="$cppad_libs_value/$POSTFIX_DIR"
- fi
--if test "$IPOPT_DIR" == "" ; then
-+if test "$IPOPT_DIR" = "" ; then
- cppad_libs_value=""
- cppad_requires_value=""
- else