summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 11:36:02 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-05 12:46:57 +0200
commitd1da9321d54dbbe70aff76b9c6968e75b69b3764 (patch)
tree636676cf1bf7c4d05a35ecdf13862b157e7d2e0f /sci-libs
parentdev-util/cookiecutter: add 1.7.3 (diff)
downloadgentoo-d1da9321d54dbbe70aff76b9c6968e75b69b3764.tar.gz
gentoo-d1da9321d54dbbe70aff76b9c6968e75b69b3764.tar.bz2
gentoo-d1da9321d54dbbe70aff76b9c6968e75b69b3764.zip
sci-libs/rtree: add 0.9.7, add py3.10
Closes: https://bugs.gentoo.org/791766 Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/rtree/Manifest1
-rw-r--r--sci-libs/rtree/metadata.xml4
-rw-r--r--sci-libs/rtree/rtree-0.9.7.ebuild30
3 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/rtree/Manifest b/sci-libs/rtree/Manifest
index 405a862ae51a..5dfbd7f55310 100644
--- a/sci-libs/rtree/Manifest
+++ b/sci-libs/rtree/Manifest
@@ -1 +1,2 @@
DIST Rtree-0.9.4.tar.gz 62017 BLAKE2B 72a979a3b9b9e9e1d18ea8646bbf860413c18420ce40946108c4f2f0e59fcb5bb64971a57936a92714e02e13419f7dc594b2371e4b44a4fd6a3e3986c19f7d85 SHA512 59981ffefedac1162faaa86ea10d7d5503da46c7ae9588a57e1a49214043de5f41bd4836965651d4cd22e7959c37cc6d586d9912568a2aaf693a0afb7895b429
+DIST Rtree-0.9.7.tar.gz 44877 BLAKE2B 4ee5ad4c478ada448a8faa5ba29bdfbb67bc2f688cb8c6f465f4637fbd890cbd997f24573b25a936b7ceb503cc0b7684a1932e6ac91a85e4c37730ee9a6d39f0 SHA512 35b39e29f6d2b9cf4e774191bed69ade515680d07213f0ba74748da11ba916b41c93dfc4f489d7320855f3722ac8b5b58bac4614ea95e6230fcffe33f4332607
diff --git a/sci-libs/rtree/metadata.xml b/sci-libs/rtree/metadata.xml
index d03728e20d7e..a0a47a2da71d 100644
--- a/sci-libs/rtree/metadata.xml
+++ b/sci-libs/rtree/metadata.xml
@@ -5,6 +5,10 @@
<email>3dprint@gentoo.org</email>
<name>Gentoo 3D Printer Project</name>
</maintainer>
+ <maintainer type="person">
+ <email>andrewammerlaan@gentoo.org</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
<longdescription>
Rtree is a ctypes Python wrapper of libspatialindex that provides a number of advanced spatial indexing
features for the spatially curious Python user.
diff --git a/sci-libs/rtree/rtree-0.9.7.ebuild b/sci-libs/rtree/rtree-0.9.7.ebuild
new file mode 100644
index 000000000000..021ea1b4638d
--- /dev/null
+++ b/sci-libs/rtree/rtree-0.9.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+MY_PN="Rtree"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="R-Tree spatial index for Python GIS"
+HOMEPAGE="https://rtree.readthedocs.io"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="sci-libs/libspatialindex"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests pytest
+
+DEPEND+="
+ test? ( dev-python/numpy[${PYTHON_USEDEP}] )
+"