summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2019-04-12 15:42:24 +0000
committerSven Wegener <swegener@gentoo.org>2019-04-12 15:44:11 +0000
commitd90c4128d5449d92fd016832a38120258e8a2813 (patch)
tree0500ffdb564ffee175ccc9feec00fb8fb05bf75c /sci-libs
parentsci-libs/libsigrok: Cleanup (diff)
downloadgentoo-d90c4128d5449d92fd016832a38120258e8a2813.tar.gz
gentoo-d90c4128d5449d92fd016832a38120258e8a2813.tar.bz2
gentoo-d90c4128d5449d92fd016832a38120258e8a2813.zip
sci-libs/libsigrok: Install udev rules, bug #671716
Closes: https://bugs.gentoo.org/671716 Signed-off-by: Sven Wegener <swegener@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libsigrok/libsigrok-0.5.1.ebuild7
-rw-r--r--sci-libs/libsigrok/libsigrok-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/sci-libs/libsigrok/libsigrok-0.5.1.ebuild b/sci-libs/libsigrok/libsigrok-0.5.1.ebuild
index 8ebbf15dc3de..5c92de1d5d3e 100644
--- a/sci-libs/libsigrok/libsigrok-0.5.1.ebuild
+++ b/sci-libs/libsigrok/libsigrok-0.5.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 udev xdg-utils
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -20,7 +20,7 @@ HOMEPAGE="https://sigrok.org/wiki/Libsigrok"
LICENSE="GPL-3"
SLOT="0/4"
-IUSE="cxx ftdi java parport python serial static-libs test usb"
+IUSE="cxx ftdi java parport python serial static-libs test +udev usb"
REQUIRED_USE="java? ( cxx ) python? ( cxx ${PYTHON_REQUIRED_USE} )"
# We also support librevisa, but that isn't in the tree ...
@@ -78,6 +78,7 @@ src_test() {
src_install() {
default
+ use udev && udev_dorules contrib/*.rules
prune_libtool_files
}
diff --git a/sci-libs/libsigrok/libsigrok-9999.ebuild b/sci-libs/libsigrok/libsigrok-9999.ebuild
index 694f44c3d603..4c9fa1e48079 100644
--- a/sci-libs/libsigrok/libsigrok-9999.ebuild
+++ b/sci-libs/libsigrok/libsigrok-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="6"
PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
-inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 xdg-utils
+inherit eutils gnome2-utils python-single-r1 java-pkg-opt-2 udev xdg-utils
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="git://sigrok.org/${PN}"
@@ -20,7 +20,7 @@ HOMEPAGE="https://sigrok.org/wiki/Libsigrok"
LICENSE="GPL-3"
SLOT="0/9999"
-IUSE="cxx ftdi java parport python serial static-libs test usb"
+IUSE="cxx ftdi java parport python serial static-libs test +udev usb"
REQUIRED_USE="java? ( cxx ) python? ( cxx ${PYTHON_REQUIRED_USE} )"
# We also support librevisa, but that isn't in the tree ...
@@ -78,6 +78,7 @@ src_test() {
src_install() {
default
+ use udev && udev_dorules contrib/*.rules
prune_libtool_files
}