summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2023-11-19 14:18:32 +0800
committerBenda Xu <heroxbd@gentoo.org>2023-11-20 00:32:16 +0800
commite377b88684bdcc28b9c080aae7349f435f9395f6 (patch)
tree56fdff037e2f23eb2c8e707ede86564a9e7e3126 /sci-libs
parentsci-libs/rocRAND: add 5.7.1 and fix_generator_alignements.patch (diff)
downloadgentoo-e377b88684bdcc28b9c080aae7349f435f9395f6.tar.gz
gentoo-e377b88684bdcc28b9c080aae7349f435f9395f6.tar.bz2
gentoo-e377b88684bdcc28b9c080aae7349f435f9395f6.zip
sci-libs/hipRAND: correct the on disk file name. Bump to 5.7.1.
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hipRAND/Manifest3
-rw-r--r--sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild (renamed from sci-libs/hipRAND/hipRAND-5.6.0.ebuild)2
-rw-r--r--sci-libs/hipRAND/hipRAND-5.7.1.ebuild36
3 files changed, 39 insertions, 2 deletions
diff --git a/sci-libs/hipRAND/Manifest b/sci-libs/hipRAND/Manifest
index bdb2c56b0452..39e54dc94d02 100644
--- a/sci-libs/hipRAND/Manifest
+++ b/sci-libs/hipRAND/Manifest
@@ -1 +1,2 @@
-DIST hipFFT-rocm-5.6.0.tar.gz 477597 BLAKE2B fdc88ac7076ab6b31ba794f9274881323fba32295bab5b90e38d8c8f336e0255b7d20dcba6e334b7bacd8b67eaac8a3ac6e11e3d490e7c95a973d16c9598922f SHA512 47d0cca92b458f8ef682b3c15fe4ccc5201370b1458e541080dc2150e98256962b78806c20b26d789b232d420eb305639fa50180e379ba123851d35d24d40cb2
+DIST hipRAND-rocm-5.6.0.tar.gz 477597 BLAKE2B fdc88ac7076ab6b31ba794f9274881323fba32295bab5b90e38d8c8f336e0255b7d20dcba6e334b7bacd8b67eaac8a3ac6e11e3d490e7c95a973d16c9598922f SHA512 47d0cca92b458f8ef682b3c15fe4ccc5201370b1458e541080dc2150e98256962b78806c20b26d789b232d420eb305639fa50180e379ba123851d35d24d40cb2
+DIST hipRAND-rocm-5.7.1.tar.gz 478352 BLAKE2B 5f435cf53d213b1d95ee8b766df2c9bc4b4d590ccf63fe867bd033eeb4b7fef67e2bde22242525686a8dee59fd811363857312481e9cb3575357c612ab519a41 SHA512 b3c51728c1d7cc37760f49f36ab7765c166f105bc5b1b6ce65ac4a1de9bb70f8e2c10f5c41f89040288b09c9257d913d745a416bd4785b71f170a4f57e1f95e2
diff --git a/sci-libs/hipRAND/hipRAND-5.6.0.ebuild b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
index d0bd5ace71e4..006440bb6a29 100644
--- a/sci-libs/hipRAND/hipRAND-5.6.0.ebuild
+++ b/sci-libs/hipRAND/hipRAND-5.6.0-r1.ebuild
@@ -9,7 +9,7 @@ inherit cmake rocm
DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipRAND"
-SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipRAND-rocm-${PV}.tar.gz"
REQUIRED_USE="${ROCM_REQUIRED_USE}"
LICENSE="MIT"
diff --git a/sci-libs/hipRAND/hipRAND-5.7.1.ebuild b/sci-libs/hipRAND/hipRAND-5.7.1.ebuild
new file mode 100644
index 000000000000..006440bb6a29
--- /dev/null
+++ b/sci-libs/hipRAND/hipRAND-5.7.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ROCM_VERSION=${PV}
+
+inherit cmake rocm
+
+DESCRIPTION="CU / ROCM agnostic hip RAND implementation"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipRAND"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipRAND/archive/refs/tags/rocm-${PV}.tar.gz -> hipRAND-rocm-${PV}.tar.gz"
+REQUIRED_USE="${ROCM_REQUIRED_USE}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RESTRICT="test"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocRAND:${SLOT}[${ROCM_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipRAND-rocm-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAMDGPU_TARGETS="$(get_amdgpu_flags)"
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ -DROCM_SYMLINK_LIBS=OFF
+ )
+
+ CXX=hipcc cmake_src_configure
+}