summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-28 11:41:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-28 12:26:50 +0100
commitf44f9b521150adead631fdee000f8136f29fb977 (patch)
tree5c83e708a94b809bdd8ad94faeb0c3ec72149b12 /sci-libs
parentsci-libs/orocos_kdl: remove old (diff)
downloadgentoo-f44f9b521150adead631fdee000f8136f29fb977.tar.gz
gentoo-f44f9b521150adead631fdee000f8136f29fb977.tar.bz2
gentoo-f44f9b521150adead631fdee000f8136f29fb977.zip
sci-libs/orocos_kdl: Install package.xml in our custom gentoo path from ebuild instead of patching
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/orocos_kdl/files/gentoo.patch10
-rw-r--r--sci-libs/orocos_kdl/orocos_kdl-1.3.1-r1.ebuild (renamed from sci-libs/orocos_kdl/orocos_kdl-1.3.1.ebuild)7
-rw-r--r--sci-libs/orocos_kdl/orocos_kdl-9999.ebuild7
3 files changed, 10 insertions, 14 deletions
diff --git a/sci-libs/orocos_kdl/files/gentoo.patch b/sci-libs/orocos_kdl/files/gentoo.patch
deleted file mode 100644
index 3766e12f589b..000000000000
--- a/sci-libs/orocos_kdl/files/gentoo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: orocos_kdl/CMakeLists.txt
-===================================================================
---- orocos_kdl.orig/CMakeLists.txt
-+++ orocos_kdl/CMakeLists.txt
-@@ -114,4 +114,4 @@ INSTALL(FILES ${PROJECT_BINARY_DIR}/oroc
- INSTALL(FILES ${PROJECT_BINARY_DIR}/orocos_kdl-config-version.cmake DESTINATION share/orocos_kdl)
- INSTALL(EXPORT OrocosKDLTargets DESTINATION share/orocos_kdl)
-
--INSTALL(FILES package.xml DESTINATION share/orocos_kdl)
-+INSTALL(FILES package.xml DESTINATION share/ros_packages/orocos_kdl)
diff --git a/sci-libs/orocos_kdl/orocos_kdl-1.3.1.ebuild b/sci-libs/orocos_kdl/orocos_kdl-1.3.1-r1.ebuild
index fac689144b57..8207c1ea2f3c 100644
--- a/sci-libs/orocos_kdl/orocos_kdl-1.3.1.ebuild
+++ b/sci-libs/orocos_kdl/orocos_kdl-1.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
REQUIRED_USE="examples? ( models )"
DOCS=( README )
-PATCHES=( "${FILESDIR}/gentoo.patch" )
if [ "${PV#9999}" != "${PV}" ] ; then
S=${WORKDIR}/${P}/orocos_kdl
@@ -66,4 +65,8 @@ src_install() {
cd "${BUILD_DIR}"
use doc && dohtml -r doc/api/html/*
use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+
+ # Need to have package.xml in our custom gentoo path
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
}
diff --git a/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild b/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild
index fac689144b57..8207c1ea2f3c 100644
--- a/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild
+++ b/sci-libs/orocos_kdl/orocos_kdl-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -33,7 +33,6 @@ DEPEND="${RDEPEND}
REQUIRED_USE="examples? ( models )"
DOCS=( README )
-PATCHES=( "${FILESDIR}/gentoo.patch" )
if [ "${PV#9999}" != "${PV}" ] ; then
S=${WORKDIR}/${P}/orocos_kdl
@@ -66,4 +65,8 @@ src_install() {
cd "${BUILD_DIR}"
use doc && dohtml -r doc/api/html/*
use examples && dobin "${BUILD_DIR}/examples/"{geometry,trajectory_example,chainiksolverpos_lma_demo}
+
+ # Need to have package.xml in our custom gentoo path
+ insinto /usr/share/ros_packages/${PN}
+ doins "${ED}/usr/share/${PN}/package.xml"
}