summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2021-09-30 07:48:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2021-09-30 07:50:40 -0400
commita6fb6e441272e7fbd2ee0368cd3dec9600feb7d6 (patch)
treec7c2743f9443a4a3f17a669622adc0d8de0c0b14 /sci-mathematics/arb
parentsci-mathematics/flint: new upstream version 2.8.0. (diff)
downloadgentoo-a6fb6e441272e7fbd2ee0368cd3dec9600feb7d6.tar.gz
gentoo-a6fb6e441272e7fbd2ee0368cd3dec9600feb7d6.tar.bz2
gentoo-a6fb6e441272e7fbd2ee0368cd3dec9600feb7d6.zip
sci-mathematics/arb: new upstream version 2.21.0.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/arb')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.21.0.ebuild38
-rw-r--r--sci-mathematics/arb/files/arb-2.21.0-gamma_fmpq-testfix.patch73
-rw-r--r--sci-mathematics/arb/files/arb-2.21.0-qa-warning-fix.patch21
4 files changed, 133 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index 15e552469781..73bb1e3d369c 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,3 +1,4 @@
DIST arb-2.17.0.tar.gz 1589083 BLAKE2B 68d5b04dca24129ceaec4e05124e35b474157cf1efbb6505121a03058e014cd4eb67b99497dbbafcf62e9e31f9d11c92f749f6e047e6b1513b6c0cc5ef8f22da SHA512 201e0cebbd1c4857d194e5531c76c6e45a478cf6965b836818919adf0fc04f0fe25e16ecd49c62a438876b67f009b872c4f3c774fe35620be0b22c5e08bdb824
DIST arb-2.18.1.tar.gz 1595831 BLAKE2B 010ae7a17a9cc1c11ded5806ff761115f3e78c48a5d8fc058eae0715b1e00e40345d4e6445a84c71c37627879648f445663dcc3bbcebdeaac8439a993ade38ee SHA512 07afb45829119bc695926dab4221051b221c2cc3952e42c9928efc74570b05fc01c97ea86b1b67c16d7a19a55b4e32dce97e08c9b72f36b33dd62bfccd19bb05
DIST arb-2.19.0.tar.gz 1606463 BLAKE2B 85d832113ae42737a460198cbf485f825a9435963a888c0d0ab87b7ed7277d158480b573fd8ace42484dd4767bf4f1a372f637cfff01f18c105fd2b62d0d019e SHA512 199d1a26edd01e3b30f7aef69a9ae29456e3db384037744a1e073007ddb93a248873dfe83f3e48f9de58a9d17ebd7dc9a22a058f4adf766599d01d7eb17db204
+DIST arb-2.21.0.tar.gz 1842021 BLAKE2B 1ab3c4d18eb1918eaee9ea9aff68d82fc33a136ff5612e5173bf0cc29e5753f2c002256d68ae7983b5677d5082ab6849c68755e7544cee24144ca4e84e4d8411 SHA512 e441f8325d3095f1d568ebf9018520aedb25b6a066678e870942efcc8ac005dbf10cdffe42bc4fdbce3ba3ac397241c1d92fb54556e444243bd56dd3d5d72664
diff --git a/sci-mathematics/arb/arb-2.21.0.ebuild b/sci-mathematics/arb/arb-2.21.0.ebuild
new file mode 100644
index 000000000000..e18ea81def99
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.21.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_BUILD_TYPE=Release
+inherit cmake
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="https://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-2+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ sci-mathematics/flint:="
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gamma_fmpq-testfix.patch"
+ "${FILESDIR}/${P}-qa-warning-fix.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING="$(usex test)"
+ )
+
+ cmake_src_configure
+}
diff --git a/sci-mathematics/arb/files/arb-2.21.0-gamma_fmpq-testfix.patch b/sci-mathematics/arb/files/arb-2.21.0-gamma_fmpq-testfix.patch
new file mode 100644
index 000000000000..179ba8887f32
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.21.0-gamma_fmpq-testfix.patch
@@ -0,0 +1,73 @@
+From 450435a84a40acc1871cd84f1caf2ea47c11a18c Mon Sep 17 00:00:00 2001
+From: fredrik <fredrik.johansson@gmail.com>
+Date: Tue, 28 Sep 2021 12:07:45 +0200
+Subject: [PATCH] fix (hopefully) spurious test failures for gamma_fmpq
+
+---
+ arb_hypgeom/gamma_fmpq.c | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+diff --git a/arb_hypgeom/gamma_fmpq.c b/arb_hypgeom/gamma_fmpq.c
+index 996a87e5..ee750d0d 100644
+--- a/arb_hypgeom/gamma_fmpq.c
++++ b/arb_hypgeom/gamma_fmpq.c
+@@ -529,22 +529,22 @@ arb_hypgeom_gamma_fmpq_outward(arb_t y, const fmpq_t x, slong prec)
+
+ if (q == 1 || q == 2 || q == 3 || q == 4 || q == 6)
+ {
+- arb_hypgeom_gamma_small_frac(t, p, q, prec);
++ arb_hypgeom_gamma_small_frac(t, p, q, prec + 4 * (m != 0));
+ }
+ else
+ {
+- arb_hypgeom_gamma_fmpq_hyp(t, a, prec);
++ arb_hypgeom_gamma_fmpq_hyp(t, a, prec + 4 * (m != 0));
+ }
+
+ /* argument reduction */
+ if (m >= 0)
+ {
+- arb_rising_fmpq_ui(u, a, m, prec);
++ arb_rising_fmpq_ui(u, a, m, prec + 4);
+ arb_mul(y, t, u, prec);
+ }
+ else
+ {
+- arb_rising_fmpq_ui(u, x, -m, prec);
++ arb_rising_fmpq_ui(u, x, -m, prec + 4);
+ arb_div(y, t, u, prec);
+ }
+
+@@ -602,7 +602,7 @@ arb_hypgeom_gamma_fmpq_taylor(arb_t y, const fmpq_t x, slong prec)
+ }
+
+ arb_set_fmpq(t, a, prec + 4);
+- success = arb_hypgeom_gamma_taylor(t, t, 0, prec);
++ success = arb_hypgeom_gamma_taylor(t, t, 0, prec + 4);
+
+ if (success)
+ {
+@@ -611,12 +611,12 @@ arb_hypgeom_gamma_fmpq_taylor(arb_t y, const fmpq_t x, slong prec)
+
+ if (m >= 0)
+ {
+- arb_rising_fmpq_ui(u, a, m, prec);
++ arb_rising_fmpq_ui(u, a, m, prec + 4);
+ arb_mul(y, t, u, prec);
+ }
+ else
+ {
+- arb_rising_fmpq_ui(u, x, -m, prec);
++ arb_rising_fmpq_ui(u, x, -m, prec + 4);
+ arb_div(y, t, u, prec);
+ }
+
+@@ -684,7 +684,7 @@ arb_hypgeom_gamma_fmpq(arb_t y, const fmpq_t x, slong prec)
+ wp = (slong) fmpz_bits(fmpq_numref(x)) - (slong) fmpz_bits(fmpq_denref(x));
+ wp = FLINT_MAX(wp, 0);
+ wp = FLINT_MIN(wp, 4 * prec);
+- wp += prec;
++ wp += prec + 4;
+
+ arb_set_fmpq(y, x, wp);
+
diff --git a/sci-mathematics/arb/files/arb-2.21.0-qa-warning-fix.patch b/sci-mathematics/arb/files/arb-2.21.0-qa-warning-fix.patch
new file mode 100644
index 000000000000..dd5440f938de
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.21.0-qa-warning-fix.patch
@@ -0,0 +1,21 @@
+From d271652d3124c9e65a97df310a141c607a0b5ee5 Mon Sep 17 00:00:00 2001
+From: fredrik <fredrik.johansson@gmail.com>
+Date: Wed, 29 Sep 2021 19:55:34 +0200
+Subject: [PATCH] add missing include
+
+---
+ acb_poly/lgamma_series.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/acb_poly/lgamma_series.c b/acb_poly/lgamma_series.c
+index 504b0cb4..d50ffb9f 100644
+--- a/acb_poly/lgamma_series.c
++++ b/acb_poly/lgamma_series.c
+@@ -10,6 +10,7 @@
+ */
+
+ #include "acb_poly.h"
++#include "acb_hypgeom.h"
+
+ void
+ _acb_log_rising_correct_branch(acb_t t,