summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/ent
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/ent')
-rw-r--r--sci-mathematics/ent/Manifest1
-rw-r--r--sci-mathematics/ent/ent-101202.ebuild29
-rw-r--r--sci-mathematics/ent/files/101202-gentoo.patch20
-rw-r--r--sci-mathematics/ent/metadata.xml8
4 files changed, 58 insertions, 0 deletions
diff --git a/sci-mathematics/ent/Manifest b/sci-mathematics/ent/Manifest
new file mode 100644
index 000000000000..634f75007ebb
--- /dev/null
+++ b/sci-mathematics/ent/Manifest
@@ -0,0 +1 @@
+DIST random-101202.zip 76200 RMD160 b21b8401fdbd2aac189fe4a442a1164b172407f8 SHA1 0f2f12dc67d1f02f77776709cf5fc5eee1d1b2e2 SHA256 c14ed62db24511848d6b37d4bf8869185b65be9042ffad5272257f3a249569ec
diff --git a/sci-mathematics/ent/ent-101202.ebuild b/sci-mathematics/ent/ent-101202.ebuild
new file mode 100644
index 000000000000..fa8a0eb052a3
--- /dev/null
+++ b/sci-mathematics/ent/ent-101202.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Pseudorandom number sequence test"
+HOMEPAGE="http://www.fourmilab.ch/random/"
+SRC_URI="mirror://gentoo/random-${PV}.zip"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="public-domain"
+IUSE=""
+
+RDEPEND=""
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN} || die
+ dohtml ${PN}.html ${PN}itle.gif || die
+}
diff --git a/sci-mathematics/ent/files/101202-gentoo.patch b/sci-mathematics/ent/files/101202-gentoo.patch
new file mode 100644
index 000000000000..a71bc5050637
--- /dev/null
+++ b/sci-mathematics/ent/files/101202-gentoo.patch
@@ -0,0 +1,20 @@
+diff --git a/Makefile b/Makefile
+index 2a150cf..3f9b883 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,12 +1,12 @@
+
+ # Unix make file for random test program
+
+-CC = gcc
+-CFLAGS = -g -Wall
++CC ?= gcc
++CFLAGS ?= -g -Wall
+ #CFLAGS = -O
+
+ ent: ent.o iso8859.o randtest.o chisq.o
+- $(CC) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
++ $(CC) $(LDFLAGS) $(CFLAGS) ent.o iso8859.o randtest.o chisq.o -o ent -lm
+
+ ent.c: iso8859.h randtest.h
+
diff --git a/sci-mathematics/ent/metadata.xml b/sci-mathematics/ent/metadata.xml
new file mode 100644
index 000000000000..a2070de023f7
--- /dev/null
+++ b/sci-mathematics/ent/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>