summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/form
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/form')
-rw-r--r--sci-mathematics/form/Manifest1
-rw-r--r--sci-mathematics/form/form-4.1.ebuild82
-rw-r--r--sci-mathematics/form/metadata.xml12
3 files changed, 95 insertions, 0 deletions
diff --git a/sci-mathematics/form/Manifest b/sci-mathematics/form/Manifest
new file mode 100644
index 000000000000..93a5895b3d2a
--- /dev/null
+++ b/sci-mathematics/form/Manifest
@@ -0,0 +1 @@
+DIST form-4.1.tar.gz 1260530 SHA256 fb3470937d66ed5cb1af896b15058836d2c805d767adac1b9073ed2df731cbe9 SHA512 39ab2fa1e448d6d5e427cc2c92285cc27f84724addffc378f3b799fc2b3f6381b8dceb87cb980062b980885d8d81591c5c7ff7b0dbeae7b6d9a3cf0b03d58aae WHIRLPOOL 1950ebc2357a78bf7430dd35852ab538e14b2ec68df8e9d11d7adcc31c365c14175c91bee984458794346a3b66b0580bea8625eeeff8c9c0f2045bab2bb1b5f8
diff --git a/sci-mathematics/form/form-4.1.ebuild b/sci-mathematics/form/form-4.1.ebuild
new file mode 100644
index 000000000000..b035f003dc69
--- /dev/null
+++ b/sci-mathematics/form/form-4.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="Symbolic Manipulation System"
+HOMEPAGE="http://www.nikhef.nl/~form/"
+SRC_URI="http://www.nikhef.nl/~form/maindir/binaries/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="devref doc doxygen gmp mpi threads zlib"
+
+RDEPEND="
+ gmp? ( dev-libs/gmp )
+ mpi? ( virtual/mpi )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ devref? ( dev-texlive/texlive-latex )
+ doc? ( dev-texlive/texlive-latex )
+ doxygen? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i 's/LINKFLAGS = -s/LINKFLAGS =/' sources/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-scalar \
+ --enable-largefile \
+ --disable-debug \
+ --disable-static-link \
+ --with-api=posix \
+ $(use_with gmp ) \
+ $(use_enable mpi parform ) \
+ $(use_enable threads threaded ) \
+ $(use_with zlib ) \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_compile() {
+ default
+ if use devref; then
+ pushd doc/devref > /dev/null || die "doc/devref does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doc; then
+ pushd doc/manual > /dev/null || die "doc/manual does not exist"
+ LANG=C emake pdf
+ popd > /dev/null
+ fi
+ if use doxygen; then
+ pushd doc/doxygen > /dev/null || die "doc/doxygen does not exist"
+ emake html
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+ if use devref; then
+ insinto /usr/share/doc/${PF}
+ doins doc/devref/devref.pdf
+ fi
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/manual/manual.pdf
+ fi
+ if use doxygen; then
+ dohtml -r doc/doxygen/html/*
+ fi
+}
diff --git a/sci-mathematics/form/metadata.xml b/sci-mathematics/form/metadata.xml
new file mode 100644
index 000000000000..05d73a9db6bb
--- /dev/null
+++ b/sci-mathematics/form/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+A system which can efficiently manipulate huge formulas limited only by available disk space.
+</longdescription>
+ <use>
+ <flag name="devref">Build and install developers reference</flag>
+ <flag name="doxygen">Build and install API documentation</flag>
+ </use>
+</pkgmetadata>