summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-18 16:21:35 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-09-18 21:15:16 -0700
commit59675b1abf9fdc1af45f786a40fe180bdb24b55d (patch)
treeae9ccc5348236d892c8953efd75242ff7d081e58 /sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild
parentapp-emulation/diskimage-builder: 3.3.1 fix (diff)
downloadgentoo-59675b1abf9fdc1af45f786a40fe180bdb24b55d.tar.gz
gentoo-59675b1abf9fdc1af45f786a40fe180bdb24b55d.tar.bz2
gentoo-59675b1abf9fdc1af45f786a40fe180bdb24b55d.zip
sci-mathematics/geogebra-bin: new package
Bug: https://bugs.gentoo.org/719076 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild')
-rw-r--r--sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild
new file mode 100644
index 000000000000..67801b98a81b
--- /dev/null
+++ b/sci-mathematics/geogebra-bin/geogebra-bin-5.0.604.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop prefix xdg
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Mathematics software for geometry"
+HOMEPAGE="https://www.geogebra.org"
+SRC_URI="https://download.geogebra.org/installers/5.0/GeoGebra-Linux-Portable-${MY_PV}.tar.bz2
+ https://dev.gentoo.org/~gyakovlev/distfiles/Geogebra.svg"
+
+LICENSE="Geogebra CC-BY-NC-SA-3.0 GPL-3 Apache-2.0 BSD-2 BSD BSD-4 colt EPL-1.0 icu LGPL-2.1 LGPL-2.1+ MIT W3C || ( GPL-2 CDDL )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+RDEPEND="
+ dev-java/openjdk[javafx]
+ !sci-mathematics/geogebra
+"
+
+# no tests
+RESTRICT="test"
+
+src_unpack() {
+ default
+ mv -v GeoGebra-Linux-Portable-* "${P}" || die
+ rm -rf "${P}/jre"* || die
+ rm -f "${P}/geogebra-portable" || die
+}
+
+src_prepare() {
+ eapply_user
+}
+
+src_install() {
+ insinto /opt
+ doins -r geogebra
+ newbin "$(prefixify_ro "${FILESDIR}"/geogebra.sh)" geogebra
+
+ fperms 0755 /opt/geogebra/geogebra
+ doicon "${DISTDIR}/Geogebra.svg"
+ make_desktop_entry geogebra Geogebra Geogebra Science
+}
+
+src_test() {
+ ewarn "package has no tests"
+}