summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/ginac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/ginac')
-rw-r--r--sci-mathematics/ginac/Manifest3
-rw-r--r--sci-mathematics/ginac/files/ginac-1.5.1-pkgconfig.patch9
-rw-r--r--sci-mathematics/ginac/ginac-1.5.8.ebuild59
-rw-r--r--sci-mathematics/ginac/ginac-1.6.1.ebuild62
-rw-r--r--sci-mathematics/ginac/ginac-1.6.2.ebuild60
-rw-r--r--sci-mathematics/ginac/metadata.xml13
6 files changed, 206 insertions, 0 deletions
diff --git a/sci-mathematics/ginac/Manifest b/sci-mathematics/ginac/Manifest
new file mode 100644
index 000000000000..9fafd43dd3e4
--- /dev/null
+++ b/sci-mathematics/ginac/Manifest
@@ -0,0 +1,3 @@
+DIST ginac-1.5.8.tar.bz2 1003965 SHA256 8ce72e70f7539e9a2b32539e13eb651fd688d1423dd90bcf0b9c37b592cfc2dd
+DIST ginac-1.6.1.tar.bz2 1048724 SHA256 0658c4a528f37871c5ec24496373fede4e3e59d3223beaf880c75f07a9c2f680
+DIST ginac-1.6.2.tar.bz2 1048764 SHA256 0f34d255024b3fb258e44da84f9e82dfb3dc9bc15f0999b7a18204a730663bde SHA512 6625f9958a1a6167e49d3a3ca442855fa1eab88926565747fda70a8b770db34da0c001f175fa94102ecec1f823d921eba9c98daabd6ed63548bff2b31a3b49cb WHIRLPOOL 40442b8c5820165f4970e95107ce2ac8e22d1c39b60be615d00eefe1f94e061eb6407cf3e8c0bfab15b4b9974168c97ece6cc188c76a8e9484ad9ff065f87962
diff --git a/sci-mathematics/ginac/files/ginac-1.5.1-pkgconfig.patch b/sci-mathematics/ginac/files/ginac-1.5.1-pkgconfig.patch
new file mode 100644
index 000000000000..5a6784d6b802
--- /dev/null
+++ b/sci-mathematics/ginac/files/ginac-1.5.1-pkgconfig.patch
@@ -0,0 +1,9 @@
+--- ginac-1.4.4.org/ginac.pc.in 2009-03-16 21:17:22.000000000 +0530
++++ ginac-1.4.4/ginac.pc.in 2009-03-16 21:25:28.000000000 +0530
+@@ -7,5 +7,5 @@
+ Description: C++ library for symbolic calculations
+ Version: @VERSION@
+ Requires: cln >= 1.1.6
+-Libs: -L${libdir} -lginac @GINACLIB_RPATH@
++Libs: -L${libdir} -lginac
+ Cflags: -I${includedir}
diff --git a/sci-mathematics/ginac/ginac-1.5.8.ebuild b/sci-mathematics/ginac/ginac-1.5.8.ebuild
new file mode 100644
index 000000000000..e790ea18fb0b
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.5.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${S}/doc/reference"
+ #pdf generation for reference failed (1.5.1), bug #264774
+ #emake html pdf || die "emake doc reference failed"
+ emake html || die "emake ref failed"
+ cd "${S}/doc/tutorial"
+ emake ginac.pdf ginac.html || die "emake doc tutorial failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS AUTHORS || die
+
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf || die "tutorial install failed"
+ #newins reference/ginac.pdf reference.pdf || die "ref install failed"
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/* || die
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cpp examples/ginac-examples.txt
+ fi
+}
diff --git a/sci-mathematics/ginac/ginac-1.6.1.ebuild b/sci-mathematics/ginac/ginac-1.6.1.ebuild
new file mode 100644
index 000000000000..a7b49f90b918
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${S}/doc/reference"
+ #pdf generation for reference failed (1.5.1), bug #264774
+ #emake html pdf || die "emake doc reference failed"
+ emake html
+ cd "${S}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ default
+ if use doc; then
+ cd doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cpp examples/ginac-examples.txt
+ fi
+}
diff --git a/sci-mathematics/ginac/ginac-1.6.2.ebuild b/sci-mathematics/ginac/ginac-1.6.2.ebuild
new file mode 100644
index 000000000000..14791558d1a7
--- /dev/null
+++ b/sci-mathematics/ginac/ginac-1.6.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="C++ library and tools for symbolic calculations"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/GiNaC/${P}.tar.bz2"
+HOMEPAGE="http://www.ginac.de/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND=">=sci-libs/cln-1.2.2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen
+ media-gfx/transfig
+ virtual/texi2dvi
+ dev-texlive/texlive-fontsrecommended
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.5.1-pkgconfig.patch )
+
+src_configure() {
+ local myeconfargs=( --disable-rpath )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+ if use doc; then
+ export VARTEXFONTS="${T}"/fonts
+ cd "${BUILD_DIR}/doc/reference"
+ #pdf generation for reference failed (1.6.2), bug #264774
+ #emake html pdf
+ emake html
+ cd "${BUILD_DIR}/doc/tutorial"
+ emake ginac.pdf ginac.html
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+ if use doc; then
+ cd ${BUILD_DIR}/doc
+ insinto /usr/share/doc/${PF}
+ newins tutorial/ginac.pdf tutorial.pdf
+ insinto /usr/share/doc/${PF}/html/reference
+ doins -r reference/html_files/*
+ insinto /usr/share/doc/${PF}/html
+ newins tutorial/ginac.html tutorial.html
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/doc/examples/*.cpp examples/ginac-examples.*
+ fi
+}
diff --git a/sci-mathematics/ginac/metadata.xml b/sci-mathematics/ginac/metadata.xml
new file mode 100644
index 000000000000..307010c65aa3
--- /dev/null
+++ b/sci-mathematics/ginac/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang="en">
+ GiNaC is an iterated and recursive acronym for GiNaC is Not a CAS,
+ where CAS stands for Computer Algebra System. It is designed to allow
+ the creation of integrated systems that embed symbolic manipulations
+ together with more established areas of computer science (like
+ computation-intense numeric applications, graphical interfaces, etc.)
+ under one roof.
+</longdescription>
+</pkgmetadata>