summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2019-12-28 08:33:34 -0500
committerMichael Orlitzky <mjo@gentoo.org>2019-12-28 08:57:35 -0500
commit0bc78b407798d598c763f0b86fb4d951ebef77ac (patch)
tree5c04e0218eadb901d7a9b79c2d6e7c86b7f65fe5 /sci-mathematics/gp2c
parentsci-mathematics/pari: new version 2.11.2. (diff)
downloadgentoo-0bc78b407798d598c763f0b86fb4d951ebef77ac.tar.gz
gentoo-0bc78b407798d598c763f0b86fb4d951ebef77ac.tar.bz2
gentoo-0bc78b407798d598c763f0b86fb4d951ebef77ac.zip
sci-mathematics/gp2c: new package to compile GP routines to C.
This commit imports version 0.0.11.2 more or less as-is, from the sage-on-gentoo overlay where François Bissey has been maintaining it for use with SageMath. I've enabled the test suite, which passes for me. I also moved dev-lang/perl into BDEPEND, since it's run on the build host to compile function descriptions. Closes: https://bugs.gentoo.org/703488 Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics/gp2c')
-rw-r--r--sci-mathematics/gp2c/Manifest1
-rw-r--r--sci-mathematics/gp2c/gp2c-0.0.11.2.ebuild27
-rw-r--r--sci-mathematics/gp2c/metadata.xml25
3 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/gp2c/Manifest b/sci-mathematics/gp2c/Manifest
new file mode 100644
index 000000000000..28aa36077e49
--- /dev/null
+++ b/sci-mathematics/gp2c/Manifest
@@ -0,0 +1 @@
+DIST gp2c-0.0.11pl2.tar.gz 851845 BLAKE2B 599469af3e9975270e6d9f88c1209ee3da9ae9ab9bfc90abf2431e00d553d427c15a509278b099a133262b6d02d6fa3f06090bd0083c46c9488e697dc5da5245 SHA512 20f7fc61480a70d3f8811d7881e0f386a1ced522b5c538443dc0a9fe3332d37a67ba68441eb512b5fefdb761e232f9316704fa456a311651161da7b4653ca4b7
diff --git a/sci-mathematics/gp2c/gp2c-0.0.11.2.ebuild b/sci-mathematics/gp2c/gp2c-0.0.11.2.ebuild
new file mode 100644
index 000000000000..d79631921fc5
--- /dev/null
+++ b/sci-mathematics/gp2c/gp2c-0.0.11.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-"$(ver_rs 3 'pl')
+DESCRIPTION="A GP to C translator"
+HOMEPAGE="http://pari.math.u-bordeaux.fr/"
+SRC_URI="http://pari.math.u-bordeaux.fr/pub/pari/GP2C/${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Perl is run on the build host to compile the descriptions in desc/,
+# see for example desc/Makefile.am.
+BDEPEND="dev-lang/perl"
+DEPEND="sci-mathematics/pari"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure(){
+ econf --with-paricfg="${EPREFIX}/usr/share/pari/pari.cfg"
+}
diff --git a/sci-mathematics/gp2c/metadata.xml b/sci-mathematics/gp2c/metadata.xml
new file mode 100644
index 000000000000..41fcade95d92
--- /dev/null
+++ b/sci-mathematics/gp2c/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <!--
+ mjo: François maintained this package in the sage-on-gentoo overlay
+ long before I moved it into ::gentoo. You don't need an ACK from me
+ to merge his changes.
+ -->
+ <maintainer type="person">
+ <email>frp.bissey@gmail.com</email>
+ <name>François Bissey</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The gp2c compiler is a package for translating GP routines into the C
+ programming language, so that they can be compiled and used with the PARI
+ system or the GP calculator.
+ </longdescription>
+</pkgmetadata>