summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-01-13 00:49:20 +0100
committerDavid Seifert <soap@gentoo.org>2016-01-13 00:50:37 +0100
commit7697105a937fb3043f146d15b1e4a8a8679eaf0b (patch)
treed2820ba61557103314cf9a076e94e227ab8e8046 /sci-mathematics/prng
parentnet-print/cups: also fix live-ebuild (diff)
downloadgentoo-7697105a937fb3043f146d15b1e4a8a8679eaf0b.tar.gz
gentoo-7697105a937fb3043f146d15b1e4a8a8679eaf0b.tar.bz2
gentoo-7697105a937fb3043f146d15b1e4a8a8679eaf0b.zip
sci-mathematics/prng: Revbump, modernize to EAPI=6, fix #570100
Package-Manager: portage-2.2.26
Diffstat (limited to 'sci-mathematics/prng')
-rw-r--r--sci-mathematics/prng/files/prng-3.0.2-shared.patch13
-rw-r--r--sci-mathematics/prng/prng-3.0.2-r1.ebuild34
2 files changed, 42 insertions, 5 deletions
diff --git a/sci-mathematics/prng/files/prng-3.0.2-shared.patch b/sci-mathematics/prng/files/prng-3.0.2-shared.patch
index c52929396c94..109e74faa3bb 100644
--- a/sci-mathematics/prng/files/prng-3.0.2-shared.patch
+++ b/sci-mathematics/prng/files/prng-3.0.2-shared.patch
@@ -9,15 +9,18 @@ diff -Nur prng-3.0.2.orig/configure.ac prng-3.0.2/configure.ac
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
-@@ -39,6 +40,8 @@
+@@ -39,10 +40,7 @@
dnl Checks for library functions.
AC_CHECK_FUNCS(strtoul)
+-dnl Set flags for compiler
+-if test X"$GCC" = Xyes ; then
+- AC_SUBST(AM_CFLAGS,"-Wall -fomit-frame-pointer")
+-fi
+AC_CHECK_LIB([m], [pow])
-+
- dnl Set flags for compiler
- if test X"$GCC" = Xyes ; then
- AC_SUBST(AM_CFLAGS,"-Wall -fomit-frame-pointer")
+
+ AC_CONFIG_FILES([\
+ Makefile \
diff -Nur prng-3.0.2.orig/examples/Makefile.am prng-3.0.2/examples/Makefile.am
--- prng-3.0.2.orig/examples/Makefile.am 2010-10-16 18:47:52.000000000 +0100
+++ prng-3.0.2/examples/Makefile.am 2010-10-16 18:48:08.000000000 +0100
diff --git a/sci-mathematics/prng/prng-3.0.2-r1.ebuild b/sci-mathematics/prng/prng-3.0.2-r1.ebuild
new file mode 100644
index 000000000000..f3e65ff243b4
--- /dev/null
+++ b/sci-mathematics/prng/prng-3.0.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Pseudo-Random Number Generator library"
+HOMEPAGE="http://statmath.wu.ac.at/prng/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT=0
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples static-libs"
+
+PATCHES=( "${FILESDIR}/${P}-shared.patch" )
+
+src_prepare() {
+ append-cflags -std=gnu89
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ use doc && dodoc doc/${PN}.pdf
+ if use examples; then
+ rm examples/Makefile* || die
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}