summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-08-31 00:28:31 +1000
committerMark Wright <gienah@gentoo.org>2015-08-31 00:29:41 +1000
commit7a45c4dcb255f80d2bc7c891f532bc81a95ecaa8 (patch)
tree9fc43e11d7597f472b286e2a88fd2b2560fd215d /sci-mathematics/rstudio/files
parentapp-text/tesseract: add alpha keyword (diff)
downloadgentoo-7a45c4dcb255f80d2bc7c891f532bc81a95ecaa8.tar.gz
gentoo-7a45c4dcb255f80d2bc7c891f532bc81a95ecaa8.tar.bz2
gentoo-7a45c4dcb255f80d2bc7c891f532bc81a95ecaa8.zip
sci-mathematics/rstudio: Fix bug 558900, unbundle qtsingleapplication
Thanks to Helmut Jarausch for reporting, Franz Fellner for suggesting patching rstudio to use dev-qt/qtsingleapplication[qt5] rather than the bundled version. Remove sys-devel/clang upper bound, thanks to Helmut Jarausch for reporting and testing with clang-3.6.2-r100. I tested it builds with clang-3.7.0_rc3. Fix bug 558988 sci-mathematics/rstudio-0.99.473 missing qt dependencies, thanks to Oleg and Anthony Staines for reporting and testing. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sci-mathematics/rstudio/files')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.99.473-qtsingleapplication.patch60
1 files changed, 60 insertions, 0 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-0.99.473-qtsingleapplication.patch b/sci-mathematics/rstudio/files/rstudio-0.99.473-qtsingleapplication.patch
new file mode 100644
index 000000000000..bf66bd236788
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.99.473-qtsingleapplication.patch
@@ -0,0 +1,60 @@
+--- rstudio-0.99.473-orig/src/cpp/desktop/CMakeLists.txt 2015-08-12 09:58:43.000000000 +1000
++++ rstudio-0.99.473/src/cpp/desktop/CMakeLists.txt 2015-08-30 23:16:11.396175587 +1000
+@@ -93,7 +93,12 @@
+ find_package(Qt5DBus REQUIRED)
+ endif()
+
+-
++find_path(QTSINGLEAPPLIB_INCLUDE_DIR NAMES QtSingleApplication
++ PATH_SUFFIXES QtSolutions
++ PATHS
++ /usr/include/qt5)
++find_library(QTSINGLEAPPLIB Qt5Solutions_SingleApplication-2.6
++ libQt5Solutions_SingleApplication-2.6)
+
+ # disable clang warnings for qt sources
+ if(APPLE)
+@@ -113,7 +118,6 @@
+
+ set(MOC_DESKTOP_HEADER_FILES ${DESKTOP_HEADER_FILES})
+ list(REMOVE_ITEM MOC_DESKTOP_HEADER_FILES
+- ${CMAKE_CURRENT_SOURCE_DIR}/3rdparty/qtsingleapplication/qtlockedfile.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/DesktopDetectRHome.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/DesktopOptions.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/DesktopRVersion.hpp
+@@ -175,8 +179,6 @@
+ DesktopSubMenu.cpp
+ DesktopSynctex.cpp
+ DesktopNetworkAccessManager.cpp
+- 3rdparty/qtsingleapplication/qtsingleapplication.cpp
+- 3rdparty/qtsingleapplication/qtlocalpeer.cpp
+ )
+
+ if(WIN32)
+@@ -219,6 +221,7 @@
+ ${CORE_SOURCE_DIR}/include
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
++ ${QTSINGLEAPPLIB_INCLUDE_DIR}
+ ${TESTS_INCLUDE_DIR}
+ )
+
+@@ -332,6 +335,7 @@
+
+ # set link dependencies
+ target_link_libraries(rstudio
++ ${QTSINGLEAPPLIB}
+ ${QT_LIBRARIES}
+ rstudio-core
+ ${LINK_FLAGS}
+--- rstudio-0.99.473-orig/src/cpp/desktop/DesktopPosixApplication.hpp 2015-08-12 09:58:43.000000000 +1000
++++ rstudio-0.99.473/src/cpp/desktop/DesktopPosixApplication.hpp 2015-08-30 21:41:21.616934106 +1000
+@@ -16,7 +16,7 @@
+ #ifndef DESKTOP_POSIX_APPLICATION_HPP
+ #define DESKTOP_POSIX_APPLICATION_HPP
+
+-#include "3rdparty/qtsingleapplication/QtSingleApplication"
++#include <QtSingleApplication>
+
+ namespace rstudio {
+ namespace desktop {