summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2016-01-29 15:59:09 +1100
committerMark Wright <gienah@gentoo.org>2016-01-29 15:59:09 +1100
commitc812d14ee2c817bc63175175b93de6c98c544019 (patch)
treefb8da918a0275dd63f358db4df8c7198a3f31da8 /sci-mathematics/rstudio
parentwww-client/firefox: remove old and vulnerable 38.4 (diff)
parentsci-mathematics/rstudio: cosmetic changes to PATCHES array in 0.99.486-r1 (diff)
downloadgentoo-c812d14ee2c817bc63175175b93de6c98c544019.tar.gz
gentoo-c812d14ee2c817bc63175175b93de6c98c544019.tar.bz2
gentoo-c812d14ee2c817bc63175175b93de6c98c544019.zip
sci-mathematics/rstudio: Thanks to tomboy-64 for fixing bug Bug 534152 - sci-mathematics/rstudio - add systemd support
Diffstat (limited to 'sci-mathematics/rstudio')
-rw-r--r--sci-mathematics/rstudio/files/rstudio-0.99.486-systemd.patch22
-rw-r--r--sci-mathematics/rstudio/files/rstudio-server.conf2
-rw-r--r--sci-mathematics/rstudio/files/rstudio-server.service.in10
-rw-r--r--sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild (renamed from sci-mathematics/rstudio/rstudio-0.99.486.ebuild)22
4 files changed, 48 insertions, 8 deletions
diff --git a/sci-mathematics/rstudio/files/rstudio-0.99.486-systemd.patch b/sci-mathematics/rstudio/files/rstudio-0.99.486-systemd.patch
new file mode 100644
index 000000000000..4c7eda39cc29
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-0.99.486-systemd.patch
@@ -0,0 +1,22 @@
+diff -Naur /tmp/rstudio.org/work/rstudio-0.99.486/src/cpp/server/CMakeLists.txt ./work/rstudio-0.99.486/src/cpp/server/CMakeLists.txt
+--- /tmp/rstudio.org/work/rstudio-0.99.486/src/cpp/server/CMakeLists.txt 2015-12-10 19:29:24.408267862 +0100
++++ ./work/rstudio-0.99.486/src/cpp/server/CMakeLists.txt 2015-12-10 19:35:24.660194216 +0100
+@@ -208,17 +208,12 @@
+ DESTINATION ${DISTRO_SHARE}/${RSERVER_UPSTART_DIR})
+
+ # install configured systemd profile
+- set(RSERVER_SYSTEMD_DIR "extras/systemd")
++ set(RSERVER_SYSTEMD_DIR "lib/systemd/system")
+ set(RSERVER_SYSTEMD_PROFILE "${RSERVER_SYSTEMD_DIR}/rstudio-server.service")
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_SYSTEMD_PROFILE}.in
+ ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE})
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE}
+ DESTINATION ${RSERVER_SYSTEMD_DIR})
+- set(RSERVER_SYSTEMD_PROFILE_REDHAT "${RSERVER_SYSTEMD_DIR}/rstudio-server.redhat.service")
+- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT}.in
+- ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT})
+- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${RSERVER_SYSTEMD_PROFILE_REDHAT}
+- DESTINATION ${RSERVER_SYSTEMD_DIR})
+
+ endif()
+
diff --git a/sci-mathematics/rstudio/files/rstudio-server.conf b/sci-mathematics/rstudio/files/rstudio-server.conf
index ebf1a1649169..34e93e9fab0b 100644
--- a/sci-mathematics/rstudio/files/rstudio-server.conf
+++ b/sci-mathematics/rstudio/files/rstudio-server.conf
@@ -32,4 +32,4 @@ rsession-which-r=/usr/bin/R
# To limit the users who can login to RStudio to the members
# of a specific group, you use the auth-required-user-group
# setting
-auth-required-user-group=rstudio_users
+auth-required-user-group=rstudio-server
diff --git a/sci-mathematics/rstudio/files/rstudio-server.service.in b/sci-mathematics/rstudio/files/rstudio-server.service.in
new file mode 100644
index 000000000000..fb3e37305e00
--- /dev/null
+++ b/sci-mathematics/rstudio/files/rstudio-server.service.in
@@ -0,0 +1,10 @@
+[Unit]
+Description=RStudio Server
+
+[Service]
+Type=forking
+ExecStart=${CMAKE_INSTALL_PREFIX}/bin/rserver
+Restart=on-failure
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sci-mathematics/rstudio/rstudio-0.99.486.ebuild b/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild
index 64818de5367e..764c9da06e46 100644
--- a/sci-mathematics/rstudio/rstudio-0.99.486.ebuild
+++ b/sci-mathematics/rstudio/rstudio-0.99.486-r1.ebuild
@@ -89,6 +89,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
# test? ( dev-java/junit:4 )
+PATCHES=(
+ "${FILESDIR}/${PN}-0.98.490-prefs.patch"
+ "${FILESDIR}/${PN}-0.99.473-paths.patch"
+ "${FILESDIR}/${PN}-0.99.473-clang-pandoc.patch"
+ "${FILESDIR}/${PN}-0.98.490-linker_flags.patch"
+ "${FILESDIR}/${PN}-0.98.1091-boost-1.57.patch"
+ "${FILESDIR}/${PN}-0.99.473-qtsingleapplication.patch"
+ "${FILESDIR}/${PN}-0.99.486-systemd.patch"
+)
+
src_unpack() {
unpack ${P}.tar.gz gwt-${GWT_VER}.zip
cd "${S}" || die
@@ -127,13 +137,11 @@ src_prepare() {
egit_clean
- epatch \
- "${FILESDIR}"/${PN}-0.98.490-prefs.patch \
- "${FILESDIR}"/${PN}-0.99.473-paths.patch \
- "${FILESDIR}"/${PN}-0.99.473-clang-pandoc.patch \
- "${FILESDIR}"/${PN}-0.98.490-linker_flags.patch \
- "${FILESDIR}"/${PN}-0.98.1091-boost-1.57.patch \
- "${FILESDIR}"/${PN}-0.99.473-qtsingleapplication.patch
+ epatch "${PATCHES[@]}"
+
+ # Enable CMake to install our .service file for systemd usage
+ mkdir -vp "${S}/src/cpp/server/lib/systemd/system" || die
+ cp -v "${FILESDIR}/rstudio-server.service.in" "${S}/src/cpp/server/lib/systemd/system/" || die
# Adding -DDISTRO_SHARE=... to append-flags breaks cmake so using
# this sed hack for now. ~RMH