summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-08-05 00:53:15 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-08-05 01:51:26 -0500
commit9f25ff6dfa6b7631f53b8e1e5a8144f07f1cc15f (patch)
tree440eb4771b37297bdab44590870a072a02a43a24 /sci-mathematics/slepc
parentsci-libs/gmsh: package migration from ::science overlay (diff)
downloadgentoo-9f25ff6dfa6b7631f53b8e1e5a8144f07f1cc15f.tar.gz
gentoo-9f25ff6dfa6b7631f53b8e1e5a8144f07f1cc15f.tar.bz2
gentoo-9f25ff6dfa6b7631f53b8e1e5a8144f07f1cc15f.zip
sci-mathematics/slepc: port to EAPI 7
Package-Manager: Portage-2.3.70, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'sci-mathematics/slepc')
-rw-r--r--sci-mathematics/slepc/slepc-3.11.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/sci-mathematics/slepc/slepc-3.11.1.ebuild b/sci-mathematics/slepc/slepc-3.11.1.ebuild
index cfd41a75da89..52212cabfd52 100644
--- a/sci-mathematics/slepc/slepc-3.11.1.ebuild
+++ b/sci-mathematics/slepc/slepc-3.11.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit eutils flag-o-matic python-any-r1 toolchain-funcs versionator
+inherit eutils flag-o-matic python-any-r1 toolchain-funcs
DESCRIPTION="Scalable Library for Eigenvalue Problem Computations"
HOMEPAGE="http://slepc.upv.es/"
@@ -16,9 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="complex-scalars doc mpi"
-PETSC_PV="$(get_version_component_range 1-2 ${PV})"
RDEPEND="
- =sci-mathematics/petsc-${PETSC_PV}*:=[mpi=,complex-scalars=]
+ =sci-mathematics/petsc-$(ver_cut 1-2)*:=[mpi=,complex-scalars=]
sci-libs/arpack[mpi=]
mpi? ( virtual/mpi )
"
@@ -29,7 +28,7 @@ DEPEND="${RDEPEND}
dev-util/cmake
"
-MAKEOPTS="${MAKEOPTS} -j1 V=1"
+MAKEOPTS="${MAKEOPTS} V=1"
src_prepare() {
default
@@ -70,6 +69,7 @@ src_install() {
if use doc ; then
dodoc docs/slepc.pdf
- dohtml -r docs/*.html docs/manualpages
+ docinto html
+ dodoc -r docs/*.html docs/manualpages
fi
}