summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-05-18 13:52:09 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-05-18 13:52:09 +0700
commit4c713da876b860a151768a5aa03268a2106c321a (patch)
tree24dcbcf48e88d46f340ec473fee202b2ee9d1b0a /sci-mathematics/wxmaxima
parentx11-misc/xvfb-run: x86 stable wrt bug #782481 (diff)
downloadgentoo-4c713da876b860a151768a5aa03268a2106c321a.tar.gz
gentoo-4c713da876b860a151768a5aa03268a2106c321a.tar.bz2
gentoo-4c713da876b860a151768a5aa03268a2106c321a.zip
sci-mathematics/wxmaxima: bump to 21.05.1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-21.05.1.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index c53f9dbbb35b..39b375b5aa70 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-20.12.2.tar.gz 16262617 BLAKE2B 2f9f910f565158b2011f014d96747498c6286a95bdb69f9b6b2f82a37a569e8a02abbae5cbb9ae2ac1e78d0b976487666794b267c1c40c1245df08c752486403 SHA512 1c3e3f68a2fa2cd798dfb05c52e7ddf3193a15cb45282553c280914bd524d463ad27acc89898cb4a292ff236699d1ec2abb70d83fa52cb126123ab8e2fcd5ceb
DIST wxmaxima-21.01.0.tar.gz 16220587 BLAKE2B b987e8c44c253484d152092093ab9154b7c2a5817c584bc1a4f4a0e5beec3ec2e0bc6995aea6ba28df2223b039ca97905225cc2524840174b2c99a5f7774dab2 SHA512 aec5aa5d3a9883e9b21b890c133684004576411a8341f3913ae548175979ad1f07a16d0fccd24c7757d40f4d06b4070b00fa7ef54f73f26b99c825e03e2a408b
DIST wxmaxima-21.04.0.tar.gz 17684730 BLAKE2B a3b12970ad976a3ee3fc237b6d60f52d460e87997b869825d17645daa0f82bcc6f7999188fe4c92bba819d7a895cff468ff273ab62ab30f38a7a54a6dba47786 SHA512 723373c9fd9877bce38a205455e6ac58a48a61ac3ad0be5c09d0b24abeebd35af481f19efe5de08a2507f1198a8b4b6cfa987c50e4d4a580b4e05ec2c3e5a4f7
+DIST wxmaxima-21.05.1.tar.gz 17782450 BLAKE2B cf52c26342631810fd121ce89af98784bc243e650e3db3a26b577f63fffe63380c7af4db3d5f97ef3330455051ec0bc8349726cf70817dd24e7206dd0d274ef8 SHA512 beb100c5aba34a90e2c5c0f54022948e72e1b3f72862823fc23973abec644ed0f615d3c82499738c17d49d1c9af9ab6b868486d0187ee9971a7e6b017eda10cd
diff --git a/sci-mathematics/wxmaxima/wxmaxima-21.05.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-21.05.1.ebuild
new file mode 100644
index 000000000000..86038f4610e9
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-21.05.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake_src_prepare
+
+ sed -e "s|GPL.txt ||g" -e "s|share/doc/${PN}|share/doc/${PF}|g" -i CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f locales/manual/${1}.po
+ rm -f info/${PN}.${1}.md
+ rm -f info/${PN}.${1}.html
+ sed -e "\\|/${1}/wxmaxima.1|d" -i data/CMakeLists.txt
+ }
+ l10n_find_plocales_changes locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWXM_UNIT_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ # Just run the unit tests manually for now as tests fail in a non-descriptive
+ # way even with virtualx
+ # bug #736695
+ cd "${BUILD_DIR}/test/unit_tests" || die
+
+ local tests=(
+ AFontSize
+ CellPtr
+ ImgCell
+ )
+
+ local test
+ for test in "${tests[@]}" ; do
+ ./test_${test} || die "Unit test ${test} failed!"
+ done
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake_src_install
+}