summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-16 15:33:19 +0100
committerSam James <sam@gentoo.org>2022-07-16 15:33:29 +0100
commit375d573b7600fb7833d6412c1ba56e4faab957aa (patch)
treea3aeadf5d142d641056ec8dbc4e345421bab4415 /sci-mathematics
parentnet-misc/gsasl: add 2.0.1 (diff)
downloadgentoo-375d573b7600fb7833d6412c1ba56e4faab957aa.tar.gz
gentoo-375d573b7600fb7833d6412c1ba56e4faab957aa.tar.bz2
gentoo-375d573b7600fb7833d6412c1ba56e4faab957aa.zip
sci-mathematics/cgal: add 5.5
Closes: https://bugs.gentoo.org/850697 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/cgal/Manifest2
-rw-r--r--sci-mathematics/cgal/cgal-5.5.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/sci-mathematics/cgal/Manifest b/sci-mathematics/cgal/Manifest
index aad220c3892d..5feb683c994f 100644
--- a/sci-mathematics/cgal/Manifest
+++ b/sci-mathematics/cgal/Manifest
@@ -2,3 +2,5 @@ DIST CGAL-5.2-doc_html.tar.xz 51123300 BLAKE2B 748b94d199343402baf6aef298b352fc2
DIST CGAL-5.2.tar.xz 23250240 BLAKE2B eb80a81dd01b2b2e30fe72f45cceee0861b36f47e395d1c905f8551e23d57c36dd9a7c66e32f6c2a0a2cfbd4c780fd5d5ae098709bfc1072e7ac7f761d328fd3 SHA512 8dddec18bd7e375ea3b18c636ddb2ca4f3a318e177305058f702206b830e2605837024e4b1265789f1bdc46dda80133d6fa8d61a036cda3c93a227f4c244cc1a
DIST CGAL-5.4.1-doc_html.tar.xz 50436088 BLAKE2B 9f293349f054094ecdce7a04ca1f276c56e824b4c9edd7ef82b9c450e3bde5ae26c9e6d06c5feea370c345d2b419cd426427ce34f329ea9a88ad5fa5931a0446 SHA512 5167a0fb0e390ab72c7d6106bc7d34e4a6c927f9634b02f71b675f8456d17cdcbc4a5d944c5ebf5ba1d6b635f469ee474c484913b768bff8a7c8ba52669373e8
DIST CGAL-5.4.1.tar.xz 24110884 BLAKE2B 2d01404333fdaa00d66028decbaa522d6767290e2f5be5c2b7d0323d16b9b44cd00fe58fb7d20cb02b2731893bc251bcdd4de7013107bc1d4c086e999bbf240d SHA512 751871952173c31b356284e12f3cd0840863dad51c8dad5eb8894f8285470d0e23b6b09d97d60c4ffe6eb93b14ff141a18e381eab07ea29cb48923e90f9b657b
+DIST CGAL-5.5-doc_html.tar.xz 53145672 BLAKE2B 7a575f09eed2fd97f3e68f37428d4ab41c267a6e4c158e653a8c2b5a17f2c56a31b64937fa161d3f256b473a1e617acbce2f3bfb71c2e810b8b0335b57a8b54c SHA512 41e16b44b93664ddd5185358165cce99f149fa33bdb308ce7230550ee79e3603c24df5b8d4f67de324ebf7e8a8c1e343e6d76341464cedd9d9af50f5d512af3b
+DIST CGAL-5.5.tar.xz 24156768 BLAKE2B e5f02cd082abfa8443e65430ed366cfdc3736c6a7af37284969ddd558ede1aa6c881d6928c65708504fd58f68ea01f56aa0749267d6dc83fd54f0b28e8c01374 SHA512 7fa6bf6c046727a9e0bce7cbde34cbe85979127a1ad0904f2865be83a80e89fa9af5118e5647572414f8096d29ecc808ee471d4bd3e7ecd41338be649b549290
diff --git a/sci-mathematics/cgal/cgal-5.5.ebuild b/sci-mathematics/cgal/cgal-5.5.ebuild
new file mode 100644
index 000000000000..2c573efaccb6
--- /dev/null
+++ b/sci-mathematics/cgal/cgal-5.5.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Modules provided by dev-cpp/eigen
+CMAKE_REMOVE_MODULES_LIST=( FindEigen3 )
+inherit cmake
+
+MY_P=CGAL-${PV}
+DESCRIPTION="C++ library for geometric algorithms and data structures"
+HOMEPAGE="https://www.cgal.org/"
+SRC_URI="
+ https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}.tar.xz
+ doc? ( https://github.com/CGAL/cgal/releases/download/v${PV}/${MY_P}-doc_html.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-3 GPL-3 Boost-1.0"
+SLOT="0/14"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-cpp/eigen
+ dev-libs/boost:=[threads(+)]
+ dev-libs/gmp:=[cxx]
+ dev-libs/mpfr:=
+ sys-libs/zlib
+ x11-libs/libX11:=
+ virtual/glu:=
+ virtual/opengl:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-arch/xz-utils
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.11.1-fix-buildsystem.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCGAL_INSTALL_LIB_DIR="$(get_libdir)"
+ -DCGAL_INSTALL_CMAKE_DIR="$(get_libdir)/cmake/CGAL"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( "${WORKDIR}"/doc_html/. )
+
+ cmake_src_install
+
+ if use examples; then
+ dodoc -r examples demo
+ fi
+}