summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-02-17 13:30:34 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-02-17 14:20:49 +0100
commit397b9fbefd699b26d9f8779cfc6a2d322e83365b (patch)
treec5496004252ce46d759a20c919669e540d4f639e /sci-mathematics
parentapp-admin/ansible-lint: deselect more network-dependent tests (diff)
downloadgentoo-397b9fbefd699b26d9f8779cfc6a2d322e83365b.tar.gz
gentoo-397b9fbefd699b26d9f8779cfc6a2d322e83365b.tar.bz2
gentoo-397b9fbefd699b26d9f8779cfc6a2d322e83365b.zip
sci-mathematics/coq: enable doc
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/coq/coq-8.15.0-r1.ebuild (renamed from sci-mathematics/coq/coq-8.15.0.ebuild)33
1 files changed, 17 insertions, 16 deletions
diff --git a/sci-mathematics/coq/coq-8.15.0.ebuild b/sci-mathematics/coq/coq-8.15.0-r1.ebuild
index b02fe03c702c..1bc1ac155898 100644
--- a/sci-mathematics/coq/coq-8.15.0.ebuild
+++ b/sci-mathematics/coq/coq-8.15.0-r1.ebuild
@@ -3,11 +3,11 @@
EAPI=8
-inherit desktop dune
-
MY_PV=${PV/_p/pl}
MY_P=${PN}-${MY_PV}
+inherit desktop dune
+
DESCRIPTION="Proof assistant written in O'Caml"
HOMEPAGE="http://coq.inria.fr/"
SRC_URI="https://github.com/coq/coq/archive/V${MY_PV}.tar.gz -> ${P}.tar.gz"
@@ -15,8 +15,8 @@ S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gtk debug +ocamlopt" # doc add when antlr & antlr-python are ready
+KEYWORDS="~amd64"
+IUSE="doc gtk debug +ocamlopt"
RESTRICT="test" # fails
RDEPEND="
@@ -31,15 +31,17 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-# to build docs we needantlr >=4.7, not yet in the tree
-# BDEPEND="doc? (
-# >=dev-java/antlr-4.7:4
-# dev-python/antlr-python:4
-# dev-python/beautifulsoup4
-# dev-python/pexpect
-# dev-python/sphinx_rtd_theme
-# dev-python/sphinxcontrib-bibtex
-# )"
+BDEPEND="
+ doc? (
+ >=dev-java/antlr-4.7:4
+ dev-python/antlr4-python3-runtime
+ dev-python/beautifulsoup4
+ dev-python/pexpect
+ dev-python/sphinx_rtd_theme
+ dev-python/sphinxcontrib-bibtex
+ dev-tex/latexmk
+ )
+"
DOCS=( CODE_OF_CONDUCT.md CONTRIBUTING.md CREDITS INSTALL.md README.md )
@@ -51,8 +53,7 @@ src_configure() {
-docdir /usr/share/doc/${PF}
-datadir /usr/share/coq
-configdir /etc/xdg/${PN}
- # -with-doc $(usex doc)
- -with-doc no
+ -with-doc $(usex doc)
)
use debug && myconf+=( -debug )
@@ -95,7 +96,7 @@ src_install() {
syms+=( coqide )
fi
- # use doc && emake DESTDIR="${D}" install-doc-all
+ use doc && emake DESTDIR="${D}" install-doc-all
einstalldocs
# Dune installs into /usr/<libdir>/ocaml/<coq> but