summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-06-02 22:16:05 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-06-03 09:16:48 -0400
commit3ce952baca9125fa4286ae17519a974fd82ac8fc (patch)
treee240f68b524b0873e4e3b0940c9561e312ae345c /sci-mathematics
parentdev-libs/igraph: new revision with EAPI=6 and ~x86 keywords. (diff)
downloadgentoo-3ce952baca9125fa4286ae17519a974fd82ac8fc.tar.gz
gentoo-3ce952baca9125fa4286ae17519a974fd82ac8fc.tar.bz2
gentoo-3ce952baca9125fa4286ae17519a974fd82ac8fc.zip
sci-mathematics/rw: new revision with EAPI=6 and ~x86 keywords.
The main goal of the new revision is to add ~x86 keywords. In the process, the ebuild was updated to EAPI=6. That basically amounts to replacing the autotools-utils eclass stuff. Gentoo-Bug: 573728 Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/rw/rw-0.7-r1.ebuild (renamed from sci-mathematics/rw/rw-0.7.ebuild)21
1 files changed, 6 insertions, 15 deletions
diff --git a/sci-mathematics/rw/rw-0.7.ebuild b/sci-mathematics/rw/rw-0.7-r1.ebuild
index e623511f73c9..ba4627f1b9dd 100644
--- a/sci-mathematics/rw/rw-0.7.ebuild
+++ b/sci-mathematics/rw/rw-0.7-r1.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-
-inherit autotools-utils
+EAPI=6
DESCRIPTION="Compute rank-width decompositions of graphs"
AUTHORPAGE="http://pholia.tdi.informatik.uni-frankfurt.de/~philipp/"
@@ -13,23 +11,16 @@ SRC_URI="${AUTHORPAGE}/software/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
-IUSE="+executable static-libs"
+KEYWORDS="~amd64 ~amd64-linux ~x86 ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
+IUSE="+executable"
DEPEND="executable? ( >=dev-libs/igraph-0.6 )"
RDEPEND="${DEPEND}"
DOCDIR="/usr/share/doc/${PF}"
-AUTOTOOLS_IN_SOURCE_BUILD=1
-
src_configure(){
- local myeconfargs=(
- $(use_enable executable)
- --docdir="${EPREFIX}${DOCDIR}"
- )
-
- autotools-utils_src_configure
+ econf $(use_enable executable) --docdir="${EPREFIX}${DOCDIR}"
}
src_install(){
@@ -37,5 +28,5 @@ src_install(){
# program. The rest of the docs are small so just leave everything
# uncompressed.
docompress -x "${DOCDIR}"
- autotools-utils_src_install
+ default
}