summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 08:34:04 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-28 08:36:47 -0500
commit4bbb8b0f1cb8b3c8a42775c5077e610ad7f4f558 (patch)
treea92bf97a57d8a51d2a9e072b58330fff8afd23d9 /sci-mathematics
parentmedia-plugins/vdr-loadepg: version bump (diff)
downloadgentoo-4bbb8b0f1cb8b3c8a42775c5077e610ad7f4f558.tar.gz
gentoo-4bbb8b0f1cb8b3c8a42775c5077e610ad7f4f558.tar.bz2
gentoo-4bbb8b0f1cb8b3c8a42775c5077e610ad7f4f558.zip
sci-mathematics/gmp-ecm: new EAPI=7 revision.
The dependencies and build system of gmp-ecm have been improved over the years, and much of the cruft in the ebuild could simply be deleted. This commit adds an -r2, based on François Bissey's ebuild in the sage-on-gentoo overlay, to modernize things. I've manually verified the diff for sanity, and the test suite passes for me on amd64. Closes: https://bugs.gentoo.org/466498 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
new file mode 100644
index 000000000000..98a97183de0f
--- /dev/null
+++ b/sci-mathematics/gmp-ecm/gmp-ecm-7.0.4-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Elliptic Curve Method for Integer Factorization"
+HOMEPAGE="http://ecm.gforge.inria.fr/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/36224/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="+custom-tune -openmp static-libs cpu_flags_x86_sse2"
+
+DEPEND="dev-libs/gmp:="
+RDEPEND="${DEPEND}"
+
+# Can't both be enabled.
+REQUIRED_USE="x86-macos? ( !custom-tune )"
+
+S="${WORKDIR}/ecm-${PV}"
+
+pkg_pretend() {
+ tc-check-openmp
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ $(use_enable openmp) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable custom-tune asm-redc)
+}