summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-07-31 15:20:05 +0200
committerDavid Seifert <soap@gentoo.org>2016-07-31 15:23:26 +0200
commit4df89de481ecf67d98d81ebdb61ac2252000387c (patch)
tree87db0a994d1778a69cfff8838be4cb239d4f08dc /sci-mathematics
parentprofiles: Mask USE="graphicsmagick" for sci-mathematics/octave on arm (diff)
downloadgentoo-4df89de481ecf67d98d81ebdb61ac2252000387c.tar.gz
gentoo-4df89de481ecf67d98d81ebdb61ac2252000387c.tar.bz2
gentoo-4df89de481ecf67d98d81ebdb61ac2252000387c.zip
sci-mathematics/octave: Add subslot operator for media-gfx/imagemagick
Gentoo-bug: 584104 * Also add USE="graphicsmagick" and add subslot operator for media-gfx/graphicsmagick Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/metadata.xml27
-rw-r--r--sci-mathematics/octave/octave-3.6.4-r1.ebuild9
-rw-r--r--sci-mathematics/octave/octave-3.6.4.ebuild9
-rw-r--r--sci-mathematics/octave/octave-3.8.2.ebuild11
-rw-r--r--sci-mathematics/octave/octave-4.0.0-r1.ebuild9
-rw-r--r--sci-mathematics/octave/octave-4.0.0.ebuild11
-rw-r--r--sci-mathematics/octave/octave-4.0.1-r1.ebuild9
-rw-r--r--sci-mathematics/octave/octave-4.0.1.ebuild9
-rw-r--r--sci-mathematics/octave/octave-4.0.2-r1.ebuild9
9 files changed, 56 insertions, 47 deletions
diff --git a/sci-mathematics/octave/metadata.xml b/sci-mathematics/octave/metadata.xml
index 8bafaba69740..a3ecac6b94b7 100644
--- a/sci-mathematics/octave/metadata.xml
+++ b/sci-mathematics/octave/metadata.xml
@@ -1,23 +1,24 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>sci-mathematics@gentoo.org</email>
- <name>Gentoo Mathematics Project</name>
-</maintainer>
-<longdescription lang="en">
+ <maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+ </maintainer>
+ <longdescription lang="en">
Octave is a high-level language, primarily intended for numerical
computations. It provides a convenient command line interface for
solving linear and nonlinear problems numerically, and for performing
other numerical experiments. It may also be used as a batch-oriented
language.
</longdescription>
-<use>
- <flag name="glpk">Add support for <pkg>sci-mathematics/glpk</pkg> for linear programming</flag>
- <flag name="gui">Enable the graphical user interface</flag>
- <flag name="jit">(EXPERIMENTAL) enable JIT compiler</flag>
- <flag name="qhull">Add support for <pkg>media-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
- <flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
- <flag name="sparse">Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
-</use>
+ <use>
+ <flag name="glpk">Add support for <pkg>sci-mathematics/glpk</pkg> for linear programming</flag>
+ <flag name="graphicsmagick">Add support for <pkg>media-gfx/graphicsmagick</pkg></flag>
+ <flag name="gui">Enable the graphical user interface</flag>
+ <flag name="jit">(EXPERIMENTAL) enable JIT compiler</flag>
+ <flag name="qhull">Add support for <pkg>media-libs/qhull</pkg>, to allow `delaunay', `convhull', and related functions</flag>
+ <flag name="qrupdate">Add support for <pkg>sci-libs/qrupdate</pkg>for QR and Cholesky update functions</flag>
+ <flag name="sparse">Add enhanced support for sparse matrix algebra with SuiteSparse</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-mathematics/octave/octave-3.6.4-r1.ebuild b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
index 65094e6acf68..401cd70c4454 100644
--- a/sci-mathematics/octave/octave-3.6.4-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot hdf5 +imagemagick opengl postscript
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -29,9 +29,10 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
diff --git a/sci-mathematics/octave/octave-3.6.4.ebuild b/sci-mathematics/octave/octave-3.6.4.ebuild
index 67ab623ccd1a..01f833540472 100644
--- a/sci-mathematics/octave/octave-3.6.4.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot hdf5 +imagemagick opengl postscript
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -29,9 +29,10 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
diff --git a/sci-mathematics/octave/octave-3.8.2.ebuild b/sci-mathematics/octave/octave-3.8.2.ebuild
index 7d12d6f3bb33..f61595cfbfae 100644
--- a/sci-mathematics/octave/octave-3.8.2.ebuild
+++ b/sci-mathematics/octave/octave-3.8.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -30,9 +30,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
opengl? (
media-libs/freetype:2=
diff --git a/sci-mathematics/octave/octave-4.0.0-r1.ebuild b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
index 1e40ef2f6dcd..07eee35902bf 100644
--- a/sci-mathematics/octave/octave-4.0.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -31,9 +31,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
diff --git a/sci-mathematics/octave/octave-4.0.0.ebuild b/sci-mathematics/octave/octave-4.0.0.ebuild
index 6702068a95bf..4da0aa4b91ed 100644
--- a/sci-mathematics/octave/octave-4.0.0.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -31,9 +31,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
diff --git a/sci-mathematics/octave/octave-4.0.1-r1.ebuild b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
index 1b0a27f7b8e1..13da145cd869 100644
--- a/sci-mathematics/octave/octave-4.0.1-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -31,9 +31,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
diff --git a/sci-mathematics/octave/octave-4.0.1.ebuild b/sci-mathematics/octave/octave-4.0.1.ebuild
index 2355b918ccdc..4da0aa4b91ed 100644
--- a/sci-mathematics/octave/octave-4.0.1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -31,9 +31,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04
diff --git a/sci-mathematics/octave/octave-4.0.2-r1.ebuild b/sci-mathematics/octave/octave-4.0.2-r1.ebuild
index 1b0a27f7b8e1..13da145cd869 100644
--- a/sci-mathematics/octave/octave-4.0.2-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.2-r1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot +graphicsmagick gui hdf5 +imagemagick java jit opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -31,9 +31,10 @@ RDEPEND="
gnuplot? ( sci-visualization/gnuplot )
gui? ( x11-libs/qscintilla:0= )
hdf5? ( sci-libs/hdf5:0= )
- imagemagick? ( || (
- media-gfx/graphicsmagick[cxx]
- media-gfx/imagemagick[cxx] ) )
+ imagemagick? (
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
+ )
java? ( >=virtual/jre-1.6.0:* )
jit? (
>=sys-devel/autoconf-archive-2015.02.04