summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-09-08 17:10:10 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-09 00:07:42 +0200
commit5eda6c0e3cd443dfa5cae9320910d4c65547affa (patch)
tree985d99d0de54a7626bbe4984ab718d07ac9f5990 /sci-mathematics
parentdev-python/flask-bootstrap: remove old (diff)
downloadgentoo-5eda6c0e3cd443dfa5cae9320910d4c65547affa.tar.gz
gentoo-5eda6c0e3cd443dfa5cae9320910d4c65547affa.tar.bz2
gentoo-5eda6c0e3cd443dfa5cae9320910d4c65547affa.zip
sci-mathematics/minisat: revbump (EAPI 2 -> 6)
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2279 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/minisat/minisat-2.2.0-r4.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sci-mathematics/minisat/minisat-2.2.0-r4.ebuild b/sci-mathematics/minisat/minisat-2.2.0-r4.ebuild
new file mode 100644
index 000000000000..20c5ee345d26
--- /dev/null
+++ b/sci-mathematics/minisat/minisat-2.2.0-r4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Small yet efficient SAT solver with reference paper"
+HOMEPAGE="http://minisat.se/Main.html"
+SRC_URI="http://minisat.se/downloads/${P}.tar.gz
+ doc? ( http://minisat.se/downloads/MiniSat.pdf )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="MIT"
+
+IUSE="debug doc extended-solver"
+
+DEPEND="sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+DOCS=( README doc/ReleaseNotes-2.2.0.txt )
+PATCHES=( "${FILESDIR}"/${P}-header_fix.patch )
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ default
+ sed -e "s/\$(CXX) \$^/\$(CXX) \$(LDFLAGS) \$^/" \
+ -i -e "s|-O3|${CFLAGS}|" mtl/template.mk || die
+}
+
+src_configure() {
+ myconf=$(usex debug d r)
+ myext=$(usex debug debug release)
+ mydir=$(usex extended-solver simp core)
+
+ tc-export CXX
+}
+
+src_compile() {
+ export MROOT="${S}"
+ emake -C ${mydir} ${myconf}
+ LIB="${PN}" emake -C ${mydir} lib${myconf}
+}
+
+src_install() {
+ insinto /usr/include/${PN}2/mtl
+ doins mtl/*.h
+
+ insinto /usr/include/${PN}2/core
+ doins core/Solver*.h
+
+ insinto /usr/include/${PN}2/simp
+ doins simp/Simp*.h
+
+ insinto /usr/include/${PN}2/utils
+ doins utils/*.h
+
+ newbin ${mydir}/${PN}_${myext} ${PN}
+ newlib.a ${mydir}/lib${PN}_${myext}.a lib${PN}.a
+
+ use doc && DOCS+=( "${DISTDIR}"/MiniSat.pdf )
+ einstalldocs
+}