summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-04 12:12:03 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-04 12:12:06 +0100
commit60fa98b0f077135148088bfe62e484e3988089a4 (patch)
tree553d895a7b399bb0a4d97fbc0e012cd0fb492297 /sci-mathematics
parentsci-mathematics/why3: bump to 1.4.1 (diff)
downloadgentoo-60fa98b0f077135148088bfe62e484e3988089a4.tar.gz
gentoo-60fa98b0f077135148088bfe62e484e3988089a4.tar.bz2
gentoo-60fa98b0f077135148088bfe62e484e3988089a4.zip
sci-mathematics/easycrypt: bump to 1.0_pre20220303 (2022.03.03 snapshot)
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/easycrypt/Manifest1
-rw-r--r--sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sci-mathematics/easycrypt/Manifest b/sci-mathematics/easycrypt/Manifest
index bc308e15de2f..e53e0e9b2586 100644
--- a/sci-mathematics/easycrypt/Manifest
+++ b/sci-mathematics/easycrypt/Manifest
@@ -1 +1,2 @@
DIST easycrypt-1.0_pre20211210.tar.gz 1185137 BLAKE2B 3557a8b0423109a3b3e6e02f6d1ad88f07847d105015546c90b5a46cf514f1311390d3a6f6476c042420b91a62ad095919f7ab616adee2778165d9d081070730 SHA512 0043eac02e916dc46ed1cb4f278f148f915d09f336e904b1a711c18d62cda177e434fc13682ec095a085e458ba90ca8dd02968206af60f0b80a378f16b205553
+DIST easycrypt-1.0_pre20220303.tar.gz 1193244 BLAKE2B f4d4b0661b7c58d9dd2c344efac45aa4257b46122cef81f98ced05792c1e4dd49d332421f09d0b11a28893096042a98a7415d06e1624aaa59cea0c71f17f4bb8 SHA512 bd9f1638631c9539aea3ee369705fbaafa06d575db395b3d170642af2450b7df735a18fe8f6aa6e8904eae62bdcd30743ab734f7c17c583ece7c146fee1bcf77
diff --git a/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild b/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild
new file mode 100644
index 000000000000..84353ee281ec
--- /dev/null
+++ b/sci-mathematics/easycrypt/easycrypt-1.0_pre20220303.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=c98b014c131b6c0b147b852902953dd6c5771603
+
+inherit dune
+
+DESCRIPTION="Computer-Aided Cryptographic Proofs"
+HOMEPAGE="https://github.com/EasyCrypt/easycrypt"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/EasyCrypt/${PN}.git"
+else
+ SRC_URI="https://github.com/EasyCrypt/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${H}"
+fi
+
+LICENSE="CeCILL-B CeCILL-C"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.08.0:=[ocamlopt?]
+ >=sci-mathematics/why3-1.4:=
+ dev-ml/batteries:=
+ dev-ml/camlzip:=
+ dev-ml/dune-build-info:=
+ dev-ml/dune-site:=
+ dev-ml/ocaml-inifiles:=
+ dev-ml/pcre-ocaml:=
+ dev-ml/yojson:=
+ dev-ml/zarith:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ local theories="[\"$(ocamlc -where)/easycrypt/theories\"]"
+ sed -i "s|EcRelocate\.Sites\.theories|${theories}|g" src/ec.ml || die
+
+ default
+}