summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-27 16:54:52 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-02-27 17:26:08 -0500
commit6158424e69552c78c374535d555e2d13fd5000ea (patch)
tree2679048fed81c9854d2ef0367f88d308107efea7 /sci-mathematics
parentwww-servers/tomcat: bump to 8.5.51 (diff)
downloadgentoo-6158424e69552c78c374535d555e2d13fd5000ea.tar.gz
gentoo-6158424e69552c78c374535d555e2d13fd5000ea.tar.bz2
gentoo-6158424e69552c78c374535d555e2d13fd5000ea.zip
sci-mathematics/arb: new version 2.17.0.
Standard EAPI=7 update, and I noticed that the license has changed to LGPL-2.1+ upstream (the "plus" is mentioned in the file headers). The libdir fix was taken from François Bissey's sage-on-gentoo overlay. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/arb/Manifest1
-rw-r--r--sci-mathematics/arb/arb-2.17.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sci-mathematics/arb/Manifest b/sci-mathematics/arb/Manifest
index a8ef8a032e96..ea9228bc4d6c 100644
--- a/sci-mathematics/arb/Manifest
+++ b/sci-mathematics/arb/Manifest
@@ -1,2 +1,3 @@
DIST arb-2.11.1.tar.gz 1248835 BLAKE2B 8ba11f3a92103231c4710c0158ce0811b2a01872e1ec7b7a4a4320d27ab86688aa8733df6dd2464aa55c0a506a8a595e4c370848c78b5c3a650e647f0c6d7411 SHA512 7a014da5208b55f20c7a3cd3eb51070b09ae107b04cbbd6329925780c2ab4d7c38e1fb3619f21456fa806939818370fcae921f59eb013661b6bdd3d0971e3353
DIST arb-2.16.0.tar.gz 1526059 BLAKE2B 14f4a9b23fa6fc46659b742cc95b4970cee74cf52bda8bc696831b0a5c1f946f41f1c2bba180ad1199c55d741366b3376aeed0efbf6ee087b26f6de788519739 SHA512 171c965aeb03cd2830df8a53990403c6da480a94d44385dadfbb2d02697f7c03e8b9a217094b0ad93f796d889a1564f4b9ae9db35ef9de90f61bb2e3220911be
+DIST arb-2.17.0.tar.gz 1589083 BLAKE2B 68d5b04dca24129ceaec4e05124e35b474157cf1efbb6505121a03058e014cd4eb67b99497dbbafcf62e9e31f9d11c92f749f6e047e6b1513b6c0cc5ef8f22da SHA512 201e0cebbd1c4857d194e5531c76c6e45a478cf6965b836818919adf0fc04f0fe25e16ecd49c62a438876b67f009b872c4f3c774fe35620be0b22c5e08bdb824
diff --git a/sci-mathematics/arb/arb-2.17.0.ebuild b/sci-mathematics/arb/arb-2.17.0.ebuild
new file mode 100644
index 000000000000..5b8842f7b898
--- /dev/null
+++ b/sci-mathematics/arb/arb-2.17.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="C library for arbitrary-precision interval arithmetic"
+HOMEPAGE="http://fredrikj.net/arb/"
+SRC_URI="https://github.com/fredrik-johansson/arb/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/gmp:0=
+ dev-libs/mpfr:0=
+ >=sci-mathematics/flint-2.5.0:="
+
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ default
+
+ # The autodetection finds "lib" first, which may e.g. contain 32-bit
+ # libs during a 64-bit build.
+ #
+ # Copied from flint which has the same issues because arb is just
+ # copying flint. Of course flint doesn't have a line for itself
+ # and, it had to be added.
+ sed -e "s:{GMP_DIR}/lib\":{GMP_DIR}/$(get_libdir)\":g" \
+ -e "s:{MPFR_DIR}/lib\":{MPFR_DIR}/$(get_libdir)\":g" \
+ -e "s:{FLINT_DIR}/lib\":{FLINT_DIR}/$(get_libdir)\":g" \
+ -i configure
+}
+
+src_configure() {
+ # Not an autoconf configure script. It appears to have been cloned
+ # from the flint configure script and that not all the options
+ # offered are valid.
+ tc-export CC AR CXX
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --with-flint="${EPREFIX}/usr" \
+ --with-gmp="${EPREFIX}/usr" \
+ --with-mpfr="${EPREFIX}/usr" \
+ $(use_enable static-libs static) \
+ CFLAGS="${CPPFLAGS} ${CFLAGS}" || die
+}
+
+src_compile() {
+ emake verbose
+}
+
+src_test() {
+ # We have to set the library path otherwise a previous install of
+ # libarb may be loaded. This is in part a consequence of setting
+ # the soname/installname I think.
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ DYLD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ else
+ LD_LIBRARY_PATH="${S}" emake AT= QUIET_CC= QUIET_CXX= QUIET_AR= check
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+ dodoc README.md
+}