summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-18 19:29:39 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-18 20:37:48 +0100
commit61bd2fdc46fc2e895d15dabd68a31c19322ad37f (patch)
tree0e94ab5244f858216de9b92540da75efea81a0db /sci-mathematics
parentnet-wireless/unifi: add 7.0.25 (diff)
downloadgentoo-61bd2fdc46fc2e895d15dabd68a31c19322ad37f.tar.gz
gentoo-61bd2fdc46fc2e895d15dabd68a31c19322ad37f.tar.bz2
gentoo-61bd2fdc46fc2e895d15dabd68a31c19322ad37f.zip
sci-mathematics/lean: bump to 3.42.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/lean/Manifest1
-rw-r--r--sci-mathematics/lean/lean-3.42.0.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/sci-mathematics/lean/Manifest b/sci-mathematics/lean/Manifest
index 3ef12ca10328..ad0e723b1b3c 100644
--- a/sci-mathematics/lean/Manifest
+++ b/sci-mathematics/lean/Manifest
@@ -1,3 +1,4 @@
DIST lean-3.39.1.tar.gz 1878481 BLAKE2B b3d1760594751418d6ebb7754d733e8fdebc5e0eba25e8d4993280325ec9d40e9083af155d388d52b5edfff2e9dffbeff91caa68ccb76500dcd88ebac2af4444 SHA512 5839eb7b5f7cd2d93ab603f1a5121e0a6b55850686677f103c16ec2157dc19479f1909ea056b54e41331c28fd59a4a825741384fa431473924381b72640a04dd
DIST lean-3.40.0.tar.gz 1878547 BLAKE2B 762c12b9fee9ac405730fb4a748326e7c9603c50f44512166f94df51e8cde0096803f11d0201980e1a1c0121a2b278075bf238452254d83e2d8b7b5566355416 SHA512 4daa32b60195a9776019c3c13c3765a1f5a817d78f189c3f92859298118815af4cb47359816ebbb977f35453be358956f3680b06b5930d5cf3a4245599602873
DIST lean-3.41.0.tar.gz 1905966 BLAKE2B 1921ba4a975ed8fc6001695151bb366341e0895989a570bb7fbef1e719685945d0b7c51ed0716ff29daaf81af24ce2e289cab41b251c686a286cd94a0cf708f8 SHA512 855a56812ba5dc7cf431490957570d0fcbc4760faa1602095e708ddcc4e5a3c6aeac42133c210375d4538d97c8ae90df3ab3c7e7840e8896b8d0db439e925fbf
+DIST lean-3.42.0.tar.gz 1908134 BLAKE2B 7b6403786cc1a3a2b974f8df4c2bf2921e4e374ead4290a0e263c8464a9c009fd2f62e7cf5bdbc5087d0c9bb4c57f798b9d1a4b8ee2d66152714ec2af649e196 SHA512 2f1fc1bf3aff7fa806e1cd4647380d6896d98a9191f2035d5a37cc35938de42b243188984aa2fced37bdbee3b2c3c6ef25d27bf2428bf9a0307cc3237c80560f
diff --git a/sci-mathematics/lean/lean-3.42.0.ebuild b/sci-mathematics/lean/lean-3.42.0.ebuild
new file mode 100644
index 000000000000..5d8ee8eecd4b
--- /dev/null
+++ b/sci-mathematics/lean/lean-3.42.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MAJOR=$(ver_cut 1)
+CMAKE_IN_SOURCE_BUILD="ON"
+
+inherit cmake readme.gentoo-r1
+
+DESCRIPTION="The Lean Theorem Prover"
+HOMEPAGE="https://leanprover-community.github.io/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/leanprover-community/lean.git"
+else
+ SRC_URI="https://github.com/leanprover-community/lean/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+S="${WORKDIR}/lean-${PV}/src"
+
+LICENSE="Apache-2.0"
+SLOT="0/${MAJOR}"
+IUSE="debug +threads"
+
+RDEPEND="dev-libs/gmp:="
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-CMakeLists-fix_flags.patch" )
+
+src_configure() {
+ local CMAKE_BUILD_TYPE
+ if use debug; then
+ CMAKE_BUILD_TYPE="Debug"
+ else
+ CMAKE_BUILD_TYPE="Release"
+ fi
+
+ local mycmakeargs=(
+ -DALPHA=ON
+ -DAUTO_THREAD_FINALIZATION=ON
+ -DJSON=ON # bug 833900
+ -DLEAN_EXTRA_CXX_FLAGS="${CXXFLAGS}"
+ -DMULTI_THREAD=$(usex threads)
+ -DUSE_GITHASH=OFF
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ # Disable problematic "style_check" cpplint test,
+ # this also removes the python test dependency
+ --exclude-regex style_check
+ )
+ cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+
+ local DISABLE_AUTOFORMATTING="yes"
+ local DOC_CONTENTS="You probably want to use lean with mathlib, you can either:
+ - Do not install mathlib globally and use local versions
+ - Use leanproject from sci-mathematics/mathlib-tools
+ $ leanproject global-install
+ - Use leanpkg and compile mathlib (which will take some time)
+ $ leanpkg install https://github.com/leanprover-community/mathlib"
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}