summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-07 06:14:14 +0100
committerSam James <sam@gentoo.org>2021-04-13 00:26:26 +0000
commit7451453fe804eeecce9bb644f2ec89414b0c9052 (patch)
tree1143597c36461f32ecba6931335efeba8801a2a5 /sci-mathematics
parentsci-libs/tensorflow: call pkg-config via toolchain-funcs.eclass helper (diff)
downloadgentoo-7451453fe804eeecce9bb644f2ec89414b0c9052.tar.gz
gentoo-7451453fe804eeecce9bb644f2ec89414b0c9052.tar.bz2
gentoo-7451453fe804eeecce9bb644f2ec89414b0c9052.zip
sci-mathematics/calc: call pkg-config via toolchain-funcs.eclass helper
This ensures we call the correct pkg-config in e.g. cross. Package-Manager: Portage-3.0.14-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/calc/calc-2.12.5.4.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/sci-mathematics/calc/calc-2.12.5.4.ebuild b/sci-mathematics/calc/calc-2.12.5.4.ebuild
index c8ebd6a8570c..d2a43a0ad77a 100644
--- a/sci-mathematics/calc/calc-2.12.5.4.ebuild
+++ b/sci-mathematics/calc/calc-2.12.5.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,8 +13,6 @@ SLOT="0"
LICENSE="LGPL-2"
KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
RDEPEND="
sys-libs/ncurses:0=
sys-libs/readline:0="
@@ -39,7 +37,7 @@ src_compile() {
LDFLAGS="${LDFLAGS}" \
CALCPAGER="${PAGER}" \
USE_READLINE="-DUSE_READLINE" \
- READLINE_LIB="-lreadline -lhistory $(pkg-config --libs ncurses) -L\"${S}\"/custom -lcustcalc" \
+ READLINE_LIB="-lreadline -lhistory $(tc-getPKG_CONFIG --libs ncurses) -L\"${S}\"/custom -lcustcalc" \
all
}