summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-11 23:58:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-11 23:58:31 +0200
commit8070e24f0d096ad0c4df319f87f6550bd4ee7388 (patch)
tree252f8b0c334ad8494ee5dfecad3025ce66e6a824 /sci-mathematics
parentwww-apps/novnc: out with the old and jankey (diff)
downloadgentoo-8070e24f0d096ad0c4df319f87f6550bd4ee7388.tar.gz
gentoo-8070e24f0d096ad0c4df319f87f6550bd4ee7388.tar.bz2
gentoo-8070e24f0d096ad0c4df319f87f6550bd4ee7388.zip
sci-mathematics/octave: Remove left-over 'use jit' calls
* https://github.com/gentoo/gentoo/pull/2288 Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/octave/files/octave-3.8.0-fix-compile.patch11
-rw-r--r--sci-mathematics/octave/octave-4.0.0-r1.ebuild2
-rw-r--r--sci-mathematics/octave/octave-4.0.0.ebuild2
-rw-r--r--sci-mathematics/octave/octave-4.0.1-r1.ebuild2
-rw-r--r--sci-mathematics/octave/octave-4.0.1.ebuild2
-rw-r--r--sci-mathematics/octave/octave-4.0.2-r2.ebuild2
-rw-r--r--sci-mathematics/octave/octave-4.0.3.ebuild2
7 files changed, 6 insertions, 17 deletions
diff --git a/sci-mathematics/octave/files/octave-3.8.0-fix-compile.patch b/sci-mathematics/octave/files/octave-3.8.0-fix-compile.patch
deleted file mode 100644
index 72931ee66283..000000000000
--- a/sci-mathematics/octave/files/octave-3.8.0-fix-compile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- octave-3.8.0-orig/libinterp/corefcn/jit-typeinfo.cc 2013-12-28 08:57:41.000000000 +1100
-+++ octave-3.8.0/libinterp/corefcn/jit-typeinfo.cc 2014-02-14 15:45:47.388031654 +1100
-@@ -872,7 +872,7 @@
- jit_operation::to_idx (const std::vector<jit_type*>& types) const
- {
- octave_idx_type numel = types.size ();
-- numel = std::max (2, numel);
-+ numel = std::max (static_cast<octave_idx_type>(2), numel);
-
- Array<octave_idx_type> idx (dim_vector (1, numel));
- for (octave_idx_type i = 0; i < static_cast<octave_idx_type> (types.size ());
diff --git a/sci-mathematics/octave/octave-4.0.0-r1.ebuild b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
index 52f52e87249c..d3b1bf379c0c 100644
--- a/sci-mathematics/octave/octave-4.0.0-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0-r1.ebuild
@@ -147,7 +147,7 @@ src_configure() {
src_compile() {
emake
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}
diff --git a/sci-mathematics/octave/octave-4.0.0.ebuild b/sci-mathematics/octave/octave-4.0.0.ebuild
index d84666836f3b..813c601c3eb7 100644
--- a/sci-mathematics/octave/octave-4.0.0.ebuild
+++ b/sci-mathematics/octave/octave-4.0.0.ebuild
@@ -142,7 +142,7 @@ src_configure() {
src_compile() {
emake
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}
diff --git a/sci-mathematics/octave/octave-4.0.1-r1.ebuild b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
index 666ac67e20b0..ab22a98cdd98 100644
--- a/sci-mathematics/octave/octave-4.0.1-r1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1-r1.ebuild
@@ -142,7 +142,7 @@ src_configure() {
src_compile() {
emake
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}
diff --git a/sci-mathematics/octave/octave-4.0.1.ebuild b/sci-mathematics/octave/octave-4.0.1.ebuild
index d84666836f3b..813c601c3eb7 100644
--- a/sci-mathematics/octave/octave-4.0.1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1.ebuild
@@ -142,7 +142,7 @@ src_configure() {
src_compile() {
emake
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}
diff --git a/sci-mathematics/octave/octave-4.0.2-r2.ebuild b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
index 666ac67e20b0..ab22a98cdd98 100644
--- a/sci-mathematics/octave/octave-4.0.2-r2.ebuild
+++ b/sci-mathematics/octave/octave-4.0.2-r2.ebuild
@@ -142,7 +142,7 @@ src_configure() {
src_compile() {
emake
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}
diff --git a/sci-mathematics/octave/octave-4.0.3.ebuild b/sci-mathematics/octave/octave-4.0.3.ebuild
index 117d91708c9a..408fc9eb09b4 100644
--- a/sci-mathematics/octave/octave-4.0.3.ebuild
+++ b/sci-mathematics/octave/octave-4.0.3.ebuild
@@ -144,7 +144,7 @@ src_configure() {
src_compile() {
default
- if use java || use jit ; then
+ if use java; then
pax-mark m "${S}/src/.libs/octave-cli"
fi
}