summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:53:15 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:13 +0100
commit88a065a37860075eee38ae2ddd1c62b05d4729e7 (patch)
tree15c1e5727ba75c6958bc28c280cf15c6f0731eab /sci-mathematics
parentsci-electronics/gsmc: clean up patches (diff)
downloadgentoo-88a065a37860075eee38ae2ddd1c62b05d4729e7.tar.gz
gentoo-88a065a37860075eee38ae2ddd1c62b05d4729e7.tar.bz2
gentoo-88a065a37860075eee38ae2ddd1c62b05d4729e7.zip
sci-mathematics/pari: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch10
-rw-r--r--sci-mathematics/pari/pari-2.11.4.ebuild9
-rw-r--r--sci-mathematics/pari/pari-2.13.0.ebuild9
3 files changed, 14 insertions, 14 deletions
diff --git a/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch b/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch
index d4044cc426d8..80f000c5f43e 100644
--- a/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch
+++ b/sci-mathematics/pari/files/pari-2.11.2-no-automagic.patch
@@ -1,5 +1,3 @@
-diff --git a/config/Makefile.SH b/config/Makefile.SH
-index 6cf5e59ee..7487941f9 100644
--- a/config/Makefile.SH
+++ b/config/Makefile.SH
@@ -74,12 +74,12 @@ case "$which_graphic_lib" in
@@ -8,8 +6,8 @@ index 6cf5e59ee..7487941f9 100644
Qt4)
- PLOTCFLAGS="\$(QTINC)"
- PLOTLIBS="\$(QTLIB) $QTLIBS"
-+ PLOTCFLAGS="`pkg-config --cflags QtGui`"
-+ PLOTLIBS="`pkg-config --libs QtGui`"
++ PLOTCFLAGS="`${PKG_CONFIG} --cflags QtGui`"
++ PLOTLIBS="`${PKG_CONFIG} --libs QtGui`"
graph=plotQt4;;
fltk)
- PLOTCFLAGS=
@@ -27,8 +25,6 @@ index 6cf5e59ee..7487941f9 100644
QTINC = $QTINC
QTLIB = $QTLIB
PLOTCFLAGS = $PLOTCFLAGS
-diff --git a/config/get_config_options b/config/get_config_options
-index 4078d2720..5c12bd491 100644
--- a/config/get_config_options
+++ b/config/get_config_options
@@ -86,6 +86,7 @@ while test $# -gt 0; do
@@ -60,8 +56,6 @@ index 4078d2720..5c12bd491 100644
Miscellaneous
--with-runtime-perl[=path-to-perl-binary] for gphelp / tex2mail
-diff --git a/config/get_graphic_lib b/config/get_graphic_lib
-index 4591f2aad..4808aab90 100644
--- a/config/get_graphic_lib
+++ b/config/get_graphic_lib
@@ -7,6 +7,7 @@ FLTK_LIBS QTDIR QTLIB"
diff --git a/sci-mathematics/pari/pari-2.11.4.ebuild b/sci-mathematics/pari/pari-2.11.4.ebuild
index 83c7847848a6..ed86287930f9 100644
--- a/sci-mathematics/pari/pari-2.11.4.ebuild
+++ b/sci-mathematics/pari/pari-2.11.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -15,7 +15,10 @@ KEYWORDS="~alpha amd64 ~arm ~hppa ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-l
IUSE="data doc fltk gmp test threads X"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( virtual/latex-base )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
DEPEND="
sys-libs/readline:0=
data? ( sci-mathematics/pari-data )
@@ -45,7 +48,7 @@ src_prepare() {
}
src_configure() {
- tc-export CC CXX
+ tc-export CC CXX PKG_CONFIG
# Workaraound to "asm operand has impossible constraints" as
# suggested in bug #499996.
diff --git a/sci-mathematics/pari/pari-2.13.0.ebuild b/sci-mathematics/pari/pari-2.13.0.ebuild
index af9b5c717ca8..bc5709ab3388 100644
--- a/sci-mathematics/pari/pari-2.13.0.ebuild
+++ b/sci-mathematics/pari/pari-2.13.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,7 +18,10 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x
IUSE="data doc fltk gmp test threads X"
RESTRICT="!test? ( test )"
-BDEPEND="doc? ( virtual/latex-base )"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )
+"
DEPEND="
sys-libs/readline:0=
data? ( sci-mathematics/pari-data )
@@ -48,7 +51,7 @@ src_prepare() {
}
src_configure() {
- tc-export CC CXX
+ tc-export CC CXX PKG_CONFIG
# Workaraound to "asm operand has impossible constraints" as
# suggested in bug #499996.