summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-03-26 23:33:22 -0400
committerMichael Orlitzky <mjo@gentoo.org>2020-03-26 23:42:07 -0400
commit9cac2697e91de4b2484524f4f5618d809a8b03ca (patch)
tree40274c560dc4953a2c43cd0467aa7a667adf163b /sci-mathematics
parentdev-python/routes02.4.1-r1: revbump, add py38, pypy3, refactor (diff)
downloadgentoo-9cac2697e91de4b2484524f4f5618d809a8b03ca.tar.gz
gentoo-9cac2697e91de4b2484524f4f5618d809a8b03ca.tar.bz2
gentoo-9cac2697e91de4b2484524f4f5618d809a8b03ca.zip
sci-mathematics/maxima: fix amd64 build with USE=clozurecl.
The maxima build needs some special-case hacking on amd64 with clozurecl. Thanks to slyfox for the patch. Closes: https://bugs.gentoo.org/665364 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/maxima-5.43.2.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sci-mathematics/maxima/maxima-5.43.2.ebuild b/sci-mathematics/maxima/maxima-5.43.2.ebuild
index 7c68f0a0e322..88f7e81d580d 100644
--- a/sci-mathematics/maxima/maxima-5.43.2.ebuild
+++ b/sci-mathematics/maxima/maxima-5.43.2.ebuild
@@ -129,9 +129,19 @@ src_configure() {
if [ ${CONF} = . ]; then
CONF=${LISPS[${n}]}
fi
+ if [[ ${CONF} == ccl ]]; then
+ # 64-bit version of clozurecl is enabled
+ # by --enable-ccl64, not by --enable-ccl.
+ # bug #665364
+ use amd64 && CONF=ccl64
+ fi
CONFS="${CONFS} --enable-${CONF}"
done
+ # Gentoo calls 'ccl' both 32-bit and 64-bit version of clozurecl.
+ # bug #665364
+ CONFS="${CONFS} --with-ccl64=ccl"
+
# enable existing translated doc
if use nls; then
for lang in ${LANGS}; do