summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2020-03-10 22:37:53 +0100
committerTupone Alfredo <tupone@gentoo.org>2020-03-10 22:37:53 +0100
commit9dc3663a2ba8a9a84fa283d166e91a249ab65d2b (patch)
treecb680107d6863216375c0232d827993c7d4c7474 /sci-mathematics
parentnet-libs/qxmpp: update the 9999 ebuild (diff)
downloadgentoo-9dc3663a2ba8a9a84fa283d166e91a249ab65d2b.tar.gz
gentoo-9dc3663a2ba8a9a84fa283d166e91a249ab65d2b.tar.bz2
gentoo-9dc3663a2ba8a9a84fa283d166e91a249ab65d2b.zip
sci-mathematics/alt-ergo: fix build with ocaml-4.09
Closes: https://bugs.gentoo.org/712032 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
index 6dc8404508d2..2f9029c56d08 100644
--- a/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
+++ b/sci-mathematics/alt-ergo/alt-ergo-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="amd64"
IUSE="examples gtk +ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.12.1[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt?]
dev-ml/zarith
gtk? ( >=dev-ml/lablgtk-2.14[sourceview,ocamlopt?] )
dev-ml/camlzip
@@ -25,6 +25,11 @@ RDEPEND="${DEPEND}"
DOCS=( CHANGES INSTALL.md README.md )
+src_prepare() {
+ default
+ find "${S}" -name \*.ml | xargs sed -i "s:Pervasives:Stdlib:g" || die
+}
+
src_configure() {
./configure --prefix /usr --libdir=/usr/$(get_libdir)
}