summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-01-06 22:40:02 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-01-06 22:57:04 +0100
commitc87d0d60f8bb736c00e00b00137c89c23fc193ac (patch)
tree5b550ab49911bf255bf7c433c4fd49e047175913 /sci-mathematics
parentnet-vpn/strongswan: bump to v5.7.2 (diff)
downloadgentoo-c87d0d60f8bb736c00e00b00137c89c23fc193ac.tar.gz
gentoo-c87d0d60f8bb736c00e00b00137c89c23fc193ac.tar.bz2
gentoo-c87d0d60f8bb736c00e00b00137c89c23fc193ac.zip
sci-mathematics/msieve: bump to v1.53
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/msieve/Manifest1
-rw-r--r--sci-mathematics/msieve/files/msieve-1.53-fix-version.patch33
-rw-r--r--sci-mathematics/msieve/msieve-1.53.ebuild57
3 files changed, 91 insertions, 0 deletions
diff --git a/sci-mathematics/msieve/Manifest b/sci-mathematics/msieve/Manifest
index 517117fcc83b..b17c16504f0f 100644
--- a/sci-mathematics/msieve/Manifest
+++ b/sci-mathematics/msieve/Manifest
@@ -1 +1,2 @@
+DIST msieve-1.53.tar.gz 976135 BLAKE2B 587007c4273b9e0ceb6dd17fb9310070b760f68f8f1c56014a168242d0989069a5257de39cba30c939b3b7e02918635d12b3153d05cd2abb9e4a6445c7ef1886 SHA512 e50e8913d38ed4108f5f2ecdbb338968edd416c56c5b7a92d8598b81fc16014ce7c7df963101c65f5bc88d1c7b2d8dbaa572efbecf53d720430a327929c9ce12
DIST msieve151.tar.gz 623885 BLAKE2B a222f49fb1c6a411e1e46a7ed153e1ba24bbb604b70034c2c0632f69096e6a08a6783b25a44ffcd2d6b6962a8713455c893eb9514fb54a13f28a5b6a9aea3867 SHA512 79c03b5d669de7f05e27fc59fa999f416f513e41cba822376b862c31439fc66cf8749034c1f8f967f745955a5271a484b23e950ffede23d3fa2737ae26dbb0d4
diff --git a/sci-mathematics/msieve/files/msieve-1.53-fix-version.patch b/sci-mathematics/msieve/files/msieve-1.53-fix-version.patch
new file mode 100644
index 000000000000..eb9a8d7ac2d0
--- /dev/null
+++ b/sci-mathematics/msieve/files/msieve-1.53-fix-version.patch
@@ -0,0 +1,33 @@
+diff --git a/common/driver.c b/common/driver.c
+index ffecfa9..3e1da78 100644
+--- a/common/driver.c
++++ b/common/driver.c
+@@ -189,10 +189,9 @@ void msieve_run(msieve_obj *obj) {
+
+ logprintf(obj, "\n");
+ logprintf(obj, "\n");
+- logprintf(obj, "Msieve v. %d.%02d (SVN %s)\n",
++ logprintf(obj, "Msieve v. %d.%02d\n",
+ MSIEVE_MAJOR_VERSION,
+- MSIEVE_MINOR_VERSION,
+- MSIEVE_SVN_VERSION);
++ MSIEVE_MINOR_VERSION);
+ start_time = time(NULL);
+ if (obj->flags & MSIEVE_FLAG_LOG_TO_STDOUT) {
+ printf("%s", ctime(&start_time));
+diff --git a/demo.c b/demo.c
+index a882732..ec3e869 100644
+--- a/demo.c
++++ b/demo.c
+@@ -81,9 +81,8 @@ void get_random_seeds(uint32 *seed1, uint32 *seed2) {
+ /*--------------------------------------------------------------------*/
+ void print_usage(char *progname) {
+
+- printf("\nMsieve v. %d.%02d (SVN %s)\n", MSIEVE_MAJOR_VERSION,
+- MSIEVE_MINOR_VERSION,
+- MSIEVE_SVN_VERSION);
++ printf("\nMsieve v. %d.%02d\n", MSIEVE_MAJOR_VERSION,
++ MSIEVE_MINOR_VERSION);
+
+ printf("\nusage: %s [options] [one_number]\n", progname);
+ printf("\nnumbers starting with '0' are treated as octal,\n"
diff --git a/sci-mathematics/msieve/msieve-1.53.ebuild b/sci-mathematics/msieve/msieve-1.53.ebuild
new file mode 100644
index 000000000000..534207e16fb4
--- /dev/null
+++ b/sci-mathematics/msieve/msieve-1.53.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A C library implementing a suite of algorithms to factor large integers"
+HOMEPAGE="https://sourceforge.net/projects/msieve/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/Msieve%20v${PV}/${PN}${PV/./}_src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="zlib +ecm mpi"
+
+# some linking troubles with gwnum
+DEPEND="
+ ecm? ( sci-mathematics/gmp-ecm[-gwnum] )
+ mpi? ( virtual/mpi )
+ zlib? ( sys-libs/zlib:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ # TODO: Integrate ggnfs properly
+ eapply \
+ "${FILESDIR}"/${PN}-1.51-reduce-printf.patch \
+ "${FILESDIR}"/${PN}-1.53-fix-version.patch
+
+ sed -i -e 's/-march=k8//' Makefile || die
+ sed -i -e 's/CC =/#CC =/' Makefile || die
+ sed -i -e 's/CFLAGS =/CFLAGS +=/' Makefile || die
+ sed -i -e 's/LIBS += -lecm/LIBS += -lecm -lgomp/' Makefile || die
+}
+
+src_compile() {
+ use ecm && export "ECM=1"
+ use mpi && export "MPI=1"
+ use zlib && export "ZLIB=1"
+ emake \
+ CC=$(tc-getCC) \
+ AR=$(tc-getAR) \
+ OPT_FLAGS="${CFLAGS}" \
+ all
+}
+
+src_install() {
+ mkdir -p "${ED%/}/usr/include/msieve"
+ mkdir -p "${ED%/}/usr/lib/"
+ mkdir -p "${ED%/}/usr/share/doc/${P}/"
+ cp include/* "${ED%/}/usr/include/msieve" || die "Failed to install"
+ cp libmsieve.a "${ED%/}/usr/lib/" || die "Failed to install"
+ dobin msieve || die "Failed to install"
+ cp Readme* "${ED%/}/usr/share/doc/${P}/" || die "Failed to install"
+}