summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-05 04:57:43 +0100
committerSam James <sam@gentoo.org>2022-07-05 04:57:50 +0100
commitca781a9ccbf5601f1a72ed2410c27939bef530f0 (patch)
tree4db92dc6df0b3f6fe1cbe0108efd332ad52c8e70 /sci-mathematics
parentx11-libs/spread-sheet-widget: drop 0.3-r1, 0.6 (diff)
downloadgentoo-ca781a9ccbf5601f1a72ed2410c27939bef530f0.tar.gz
gentoo-ca781a9ccbf5601f1a72ed2410c27939bef530f0.tar.bz2
gentoo-ca781a9ccbf5601f1a72ed2410c27939bef530f0.zip
sci-mathematics/pspp: add 1.6.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/pspp/Manifest1
-rw-r--r--sci-mathematics/pspp/pspp-1.6.2.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/sci-mathematics/pspp/Manifest b/sci-mathematics/pspp/Manifest
index 27d27d926ddf..bbd88e3c34d3 100644
--- a/sci-mathematics/pspp/Manifest
+++ b/sci-mathematics/pspp/Manifest
@@ -1,2 +1,3 @@
DIST pspp-1.6.0.tar.gz 9553836 BLAKE2B 4c12003838d7f6c3613d76626d88b24f4dac4b6f507db54b03be5f09027472704ae8ee6ce44d8756c7cd1e12a65ab836cb1f7d004220df8da47f47af85c4a771 SHA512 c8b746b9ea802a95f048e377b22d723701c5e532358aa3e4993edcc73046c4823c440dd988833b69b4ea84ac6b02a442db7daac415bef4c1081efddd9857982d
DIST pspp-1.6.1.tar.gz 9249022 BLAKE2B 306596cd428436df7f97dec627dbad6a089ff0b00b59b8152dac382a091687f4a82afd0ada7c98dea5bbc0369f0e07f1a85dcdbd84a21bfe09cbee9b43b02610 SHA512 29b475393cbe594bc93af681ec9414e56bdd664a29042017025b8f52e4e67eec1bfab638e79313a5a39929873d1d3a29095c33dbcdf40e226cc3e6010bb040a7
+DIST pspp-1.6.2.tar.gz 9249366 BLAKE2B d1a4fb352615be8d5f3af3125d10760648ab16e8d2b42dbf0632de64a5bb5bbe87b9b56661c7f600ea09c6a359e477376d3efb821280023d1825d6eb7b0a299f SHA512 fd8b6b23ae4e4a1a560bf4d20c35e761d84dcde2e220648303303f11e9c17d56285a3d5b3c26e7dad44d52ecc82fdf93fdc51a3533ff907f2ca1f1474922e31f
diff --git a/sci-mathematics/pspp/pspp-1.6.2.ebuild b/sci-mathematics/pspp/pspp-1.6.2.ebuild
new file mode 100644
index 000000000000..ead310f8260b
--- /dev/null
+++ b/sci-mathematics/pspp/pspp-1.6.2.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-any-r1 xdg
+
+DESCRIPTION="Program for statistical analysis of sampled data"
+HOMEPAGE="https://www.gnu.org/software/pspp/pspp.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+# Note: can drop test infra + which dep in next release!
+IUSE="doc examples gtk ncurses nls perl postgres test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ sci-libs/gsl:0=
+ sys-devel/gettext
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ sys-libs/zlib
+ virtual/libiconv
+ x11-libs/cairo[svg]
+ x11-libs/pango
+ gtk? (
+ dev-util/glib-utils
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:4=
+ >=x11-libs/spread-sheet-widget-0.7
+ )
+ postgres? ( dev-db/postgresql:=[server] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+pkg_pretend() {
+ ewarn "Starting with pspp-1.4.0 the pspp-mode emacs package is no longer"
+ ewarn "shipped with pspp itself, and should instead be fetched from ELPA:"
+ ewarn "https://elpa.gnu.org/packages/pspp-mode.html"
+}
+
+src_prepare() {
+ default
+
+ sed -i '/appdata$/s/appdata$/metainfo/' Makefile.in || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk gui) \
+ $(use_with perl perl-module) \
+ $(use_with postgres libpq)
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ emake html pdf
+ HTML_DOCS=( doc/pspp{,-dev}.html )
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc doc/pspp{,-dev}.pdf
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ find "${ED}" -name '*.la' -type f -delete || die
+}