summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-02-28 23:34:03 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-02-28 23:34:37 +0700
commitd6e6c92d1fb8f5001eccac2d075db369c05afadc (patch)
tree260e22928c77b47b916f1f34d257d1a75f2e4b1c /sci-mathematics
parentsci-chemistry/gromacs: add v2019.6 (diff)
downloadgentoo-d6e6c92d1fb8f5001eccac2d075db369c05afadc.tar.gz
gentoo-d6e6c92d1fb8f5001eccac2d075db369c05afadc.tar.bz2
gentoo-d6e6c92d1fb8f5001eccac2d075db369c05afadc.zip
sci-mathematics/wxmaxima: bump to 20.02.4
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-20.02.4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 3fa7e6769a4f..4eba5c07feac 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,3 +1,4 @@
DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad25516ea9b0b375daf02edac5518b113188290262bc431e8bfb4836fc1f731982a1c41c62871818e4d2cc68c96ccb31 SHA512 964de93edc5c46e98de3de405b1873fa0ed594d54f1ddc030377b023110261cb1e6b0b08dbf210551888bf890e28d16e9b1698768c93dde413d5e1918cbd234e
DIST wxmaxima-20.01.1.tar.gz 14011946 BLAKE2B ed80f02158aa0c43f37c040225010b35eea49756d8f052bcfa245d31a4a2203880463f51833ed40f2e1365473eb138269287c30a52e9f9b98ef4d9a5daac8cf5 SHA512 bff946f87db39b4bf416ef3440fdfea277f9dc9ed95debcea5798211299ae8c8dbb136a44be586a79e538b99fd38c46febf5378caab6ac31a01a01033f083937
DIST wxmaxima-20.01.3.tar.gz 14221966 BLAKE2B cdaf62f5456446fe6edf1247323faa9f0aeb84dbe890cb03028f9f441c4c6bd3e7acf806b71a86b156ea7f10664c0188517b8f2aa15536e3350e16e3307f412c SHA512 4a977bd293255ac3c010610c74aa39fba8b8468aaa9fc59707bab69ede7a427e261ce827bae8d302ee1343bb0fce5e7aa5ee3c59f17198d5c473637571667abd
+DIST wxmaxima-20.02.4.tar.gz 15242422 BLAKE2B ea9dc613fa94d046a9d461c56a9d1564001f4fa28d90a553040e85b7dd442df025521dd9501257d12c808a2e9285b7f34b04c9f10d4ce658bc6d423055c9fbd7 SHA512 d5eb0e09de55c3e6ebafeaa95957ca8bbdacac9ec1d99f6041fa99b7fa59364b3228336675f9bffa71b879b17268b80c695f16c9259bee6d5cab9ef7ed86294b
diff --git a/sci-mathematics/wxmaxima/wxmaxima-20.02.4.ebuild b/sci-mathematics/wxmaxima/wxmaxima-20.02.4.ebuild
new file mode 100644
index 000000000000..9a2b704c52cf
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-20.02.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+ rm -f "${S}"/locales/manual/${1}.po
+ rm -f "${S}"/locales/wxwin/${1}.po
+ rm -f "${S}"/info/${PN}.${1}.md
+ rm -f "${S}"/info/${PN}.${1}.html
+ }
+ l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+ docompress -x /usr/share/doc/${PF}
+ cmake-utils_src_install
+}